天天看點

PAT 1147 Heaps

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56
           

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10
           

思路:

由完全二叉樹的性質可以知道,如果根節點的索引為ind,那麼他的左孩子和右孩子分别為 i n d ∗ 2 ind*2 ind∗2, i n d ∗ 2 + 1 ind*2+1 ind∗2+1(其中ind從1開始),最多就是樹得最深一層右邊沒有節點。是以并不需要重建立出整棵樹,利用這個關系将所有節點先按索引存在數組中,然後可以完成判斷。

code:

#include <iostream>
#include<cstdio>
#include<vector>
#include<cstring>
using namespace std;
int num[1005];
vector<int> v;
int m,n;
void postOrder(int ind){
	if(ind>n) return;
	postOrder(ind*2);
	postOrder(ind*2+1);
	v.push_back(num[ind]);
}
int check(int ind){//小頂堆 
	if(ind>n) return 1;
	if(ind*2<=n&&num[ind]>num[ind*2]) return 0;
	if(ind*2+1<=n&&num[ind]>num[ind*2+1]) return 0;
	return check(ind*2)&&check(ind*2+1);	
}
int check2(int ind){//大頂堆
	if(ind>n) return 1;
	if(ind*2<=n&&num[ind]<num[ind*2]) return 0;
	if(ind*2+1<=n&&num[ind]<num[ind*2+1]) return 0;
	return check2(ind*2)&&check2(ind*2+1);
}
int main(int argc, char** argv) {
	scanf("%d %d",&m,&n);
	while(m--){
		memset(num,0,sizeof(num));
		v.clear();
		for(int i=1;i<=n;i++){
			scanf("%d",&num[i]);
		}
		if(check2(1)) printf("Max Heap\n");
		else if(check(1)) printf("Min Heap\n");
		else printf("Not Heap\n");
		
		postOrder(1);
		for(int i=0;i<v.size();i++){
			if(i==0) printf("%d",v[0]);
			else printf(" %d",v[i]);
		}
		printf("\n");
	}
	
	return 0;
}
           

繼續閱讀