The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
- Every candidate can place exactly one poster on the wall.
- All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
- The wall is divided into segments and the width of each segment is one byte.
- Each poster must completely cover a contiguous number of wall segments.
They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.
Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.
Output
For each input data set print the number of visible posters after all the posters are placed.
The picture below illustrates the case of the sample input.

Sample Input
1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
4
n(n<=10000) 個人依次貼海報,給出每張海報所貼的範圍li,ri(1<=li<=ri<=10000000) 。求出最後還能看見多少張海報。
思路:可以從後往前跟新,每次如果區間有點沒有覆寫則ans++
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<vector>
#include<set>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstdlib>
#include<cctype>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f;
const int len=1e5+5;
struct ss{
int s,e;
}p[len];
struct Node{
int l,r;
bool vis;//vis用來标記區間有沒有覆寫
int mid(){return (l+r)/2;}
}node[len<<2];
vector<int>ve;
bool flag;
void pushup(int i)
{
node[i].vis|=(node[i*2].vis&node[i*2+1].vis);
}
void built(int i,int l,int r)
{
node[i].l=l;node[i].r=r;
node[i].vis=0;
if(l==r)return ;
int mid=node[i].mid();
built(i*2,l,mid);
built(i*2+1,mid+1,r);
pushup(i);
}
void update(int i,int l,int r)
{
if(node[i].vis==1)return ;//這個區間已經完全覆寫,傳回
if(l<=node[i].l&&node[i].r<=r)//區間包含,但是區間沒有覆寫,說明有點沒有覆寫
{
flag=1;
node[i].vis=1;//區間已經覆寫
return ;
}
if(node[i].l==node[i].r)return ;
int mid=node[i].mid();
if(l<=mid)update(i*2,l,r);
if(r>mid)update(i*2+1,l,r);
pushup(i);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
scanf("%d",&n);
for(int i=0;i<n;++i)
{
scanf("%d%d",&p[i].s,&p[i].e);
ve.push_back(p[i].s);
ve.push_back(p[i].e);
}
sort(ve.begin(),ve.end());//排序
ve.erase(unique(ve.begin(),ve.end()),ve.end());//去重
int ans=0;
built(1,1,ve.size());
for(int i=n-1;i>=0;--i)
{
flag=0;
int l=lower_bound(ve.begin(),ve.end(),p[i].s)-ve.begin()+1;//離散化
int r=lower_bound(ve.begin(),ve.end(),p[i].e)-ve.begin()+1;
update(1,l,r);
if(flag)ans++;
}
cout<<ans<<endl;
}
}