天天看點

Mayor's posters(線段樹 + 離散化)

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 

  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 

Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l  i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l  i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l  i, l  i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Mayor's posters(線段樹 + 離散化)

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10
      

Sample Output

4      

解題思路:

難點在于離散化,資料過大,必須進行離散化,而且不能是普通的離散化。如果兩個相鄰海報沒有緊挨着,則在離散化的時候必須給兩個海報之間留有間隔。

打個比方:(1,10)(1,4)(5,10)這組資料,普通離散化後應該為(1,4)(1,2)(3,4),那麼答案應該為2。

(1,10)(1,3)(6,10)這組資料普通離散化後應該也為(1,4)(1,2)(3,4),答案也為2,可顯然這題答案應該為3。問題就出在未留有間隔。

解決方案就是判斷是否緊挨,若沒有緊挨,就在離散化的時候往數組裡面加一個數。在這裡我采用的是用結構體來進行離散化。

剩下的就是求海報出現的個數問題,對線段進行着色,後貼的海報着色會覆寫之前的海報,最後統計顔色的種數即可。

AC代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
const int maxn = 11111;
int x[maxn << 2], col[maxn << 4], ans, c[maxn << 2];
bool flag[maxn << 2];
struct san
{
    int a, pos;
}f[maxn << 2];
bool cmp(san v, san t)
{
    return v.a < t.a;
}
void PushDown(int rt)
{
    if(col[rt] != 0)
    {
        col[rt << 1] = col[rt << 1 | 1] = col[rt];
        col[rt] = 0;
    }
}
void update(int L, int R, int c, int l, int r, int rt)
{
    if(L <= l && R >= r)
    {
        col[rt] = c;
        return;
    }
    PushDown(rt);
    int m = (l + r) >> 1;
    if (L <= m) update(L , R , c , lson);
    if (m < R) update(L , R , c , rson);
}
void query(int l, int r, int rt)
{
    if(col[rt] != 0)
    {
        if(!flag[col[rt]])  // 用flag檢測該顔色是否之前出現過
        {
            ans++;
            flag[col[rt]] = true;
        }
        return;
    }
    if(l == r)
        return;
    int m = (l + r) >> 1;
    query(lson);
    query(rson);
}
int main()
{
    int t, n, ll, rr;
    scanf("%d", &t);
    while(t--)
    {
       ans = 0;
       memset(col , 0, sizeof(col));
       memset(flag, false, sizeof(flag));
       scanf("%d", &n);
       int k = 0;
       for(int i = 1; i <= n; i++)
       {
           scanf("%d%d", &ll, &rr); // 用f存儲左右範圍的值,是以有2*n個
           f[++k].a = ll;
           f[k].pos = k;
           f[++k].a = rr;
           f[k].pos = k;
       }
        sort(f + 1, f + k + 1, cmp); //進行第一次排序
        int t = 2 * n;
        for(int i = 2; i <= 2 * n; i++)
        {
            if(f[i].a > f[i - 1].a + 1)  //判斷是否緊挨,無需考慮兩者是否屬于同一個海報
            {
                f[++t].a = f[i - 1].a + 1; // 未緊挨就加上一個緊挨的數
                f[t].pos = 0;  // 使其pos為0,就不會在離散化時進入有效值中
            }
        }
        int m = 1;
        c[1] = 1;
        sort(f + 1, f + t + 1, cmp); // 二次排序,産生間隔
        for(int i = 2; i <= t; i++)  // 去重處理
        {
            if(f[i].a == f[i - 1]. a)
                c[i] = m;
            else
                c[i] = ++m;
        }
        for(int i = 1; i <= t; i++)  // 得到有效值
            x[f[i].pos] = c[i];
        for(int i = 1; i <= 2 * n - 1; i += 2)  //進行着色
            update(x[i], x[i + 1], i, 1, 4 * n, 1);
        query(1, 4 * n, 1);  // 求顔色種類
        printf("%d\n", ans);
    }
    return 0;
}