A Simple Task Time Limit: 2 Seconds Memory Limit: 65536 KB
Given a positive integer n and the odd integer o and the nonnegative integer p such that n = o2^p.
Example
For n = 24, o = 3 and p = 3.
Task
Write a program which for each data set:
reads a positive integer n,
computes the odd integer o and the nonnegative integer p such that n = o2^p,
writes the result.
Input
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.
Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.
Output
The output should consists of exactly d lines, one line for each data set.
Line i, 1 <= i <= d, corresponds to the i-th input and should contain two integers o and p separated by a single space such that n = o2^p.
Sample Input
1
24
Sample Output
3 3
題意:輸入1個數n找到o,p使n = o2^p成立
注意:若用2個 for循環從小到大周遊的話,會逾時
代碼:
#include <stdio.h>
#include <math.h>
int main()
{
int d;
int n;
scanf("%d",&d);
getchar();
while(d--){
int o,p,j;
scanf("%d",&n);
for(j=0;;j++)
{
if(n%2==0)
n=n/2;
else
break;
}
p=j;
o=n;
printf("%d %d\n",o,p);
}
return 0;
}