How many integers can you find
Problem Description Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
Input There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
Output For each case, output the number.
Sample Input
12 2
2 3
Sample Output
7
Author wangye
Source 2008 “Insigma International Cup” Zhejiang Collegiate Programming Contest - Warm Up(4)
Recommend wangye | We have carefully selected several similar problems for you: 1793 1794 1797 1795 1798
題目大意:
給你1個數n,再給m個數,問你1~n-1裡面有多少個數能被這m個數的任意一個數整除。
解題思路:
利用容斥原理就可以解決。
解題代碼:
#include <iostream>
#include <cstdio>
#include <vector>
using namespace std;
typedef long long ll;
int n,m,a[20];
ll gcd(ll a,ll b){
return b>0 ? gcd(b,a%b):a;
}
int main(){
while(scanf("%d%d",&n,&m)!=EOF){
int ans=0;
vector <int> v;
for(int i=0;i<m;i++){
scanf("%d",&a[i]);
if(a[i]>0) v.push_back(a[i]);
}
m=v.size();
for(int i=1;i<(1<<m);i++){
int cnt=0;
ll x=1;
for(int t=0;t<m;t++){
if(i&(1<<t)){
cnt++;
x=x*v[t]/gcd(x,v[t]);
}
}
if( cnt&1 ) ans+=(n-1)/x;
else ans-=(n-1)/x;
}
cout<<ans<<endl;
}
return 0;
}