天天看點

hdu1008 Elevator(模拟)

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 50934    Accepted Submission(s): 28102

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case. 

Sample Input

1 2

3 2 3 1

Sample Output

17

41

Author

ZHENG, Jianqiang

Source

​​ZJCPC2004​​

Recommend

JGShining   |   We have carefully selected several similar problems for you:  

​​1009​​​ 

​​​1012​​​ 

​​​1049​​​ 

​​​1013​​​ 

​​​1020​​ 

 解析:這就是一個簡單的模拟過程。

            電梯現在在 last,要去往 k 層,若上升,則花費時間為:6*(k-last)+5

                                                              若下降,則花費時間為:4*(last-k)+5

代碼:

#include<cstdio>
using namespace std;

int main()
{
  freopen("1.in","r",stdin);
  int n,i,j,k,last,sum;
  while(scanf("%d",&n),n)
    {
      sum=0,last=0;
      for(i=1;i<=n;i++)
        {
          scanf("%d",&k);
          if(k>last)sum+=6*(k-last);
          else sum+=4*(last-k);
      sum+=5,last=k;  
        }
      printf("%d\n",sum);  
    }
  return 0;
}