天天看點

A water problem A water problem

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 730    Accepted Submission(s): 377

Problem Description Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is  73  days in Xixi a year and  137  days in Haha a year. 

Now you know the days  N  after Big Bang, you need to answer whether it is the first day in a year about the two planets.  

Input There are several test cases(about  5  huge test cases).

For each test, we have a line with an only integer  N(0≤N) , the length of  N  is up to  10000000 .  

Output For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.  

Sample Input

10001
0
333
        

Sample Output

Case #1: YES
Case #2: YES
Case #3: NO
        

Author UESTC  

Source 2016中國大學生程式設計競賽 - 網絡選拔賽  

Recommend

大數除法取餘,模拟除法過程

#include <stdio.h>
#include <string.h>
using namespace std;

int main()
{
    int i;
    char ch[10000005];
    int mod, cnt = 1;
    while ( ~scanf ( "%s", ch ) )
    {
        int len = strlen(ch);
        mod = 0;
        for ( i = 0; i < len; i++ )
        {
            mod = (mod*10+ch[i]-'0')%10001;
        }
        if ( mod )
        {
            printf ( "Case #%d: NO\n", cnt );
        }
        else
        {
            printf ( "Case #%d: YES\n", cnt );
        }
        cnt++;
    }
}
           

代碼菜鳥,如有錯誤,請多包涵!!!

如果有幫助記得鼓勵我一下,謝謝!!!