天天看點

PAT 甲級 1032 SharingInput Specification:Output Specification:Sample Input 1:Sample Output 1:Sample Input 2:Sample Output 2:

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, loading and being are stored as showed in Figure 1.

PAT 甲級 1032 SharingInput Specification:Output Specification:Sample Input 1:Sample Output 1:Sample Input 2:Sample Output 2:

Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of i in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (≤10​5), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by −1.``

Then N lines follow, each describes a node in the format:

Address Data Next
           

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from { a-z, A-Z }, and Next is the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output -1 instead.

Sample Input 1:

11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
           

Sample Output 1:

67890
           

Sample Input 2:

00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
           

Sample Output 2:

-1
           

題目大意

提供靜态連結清單,給出兩個靜态連結清單的連結清單頭,然後找出兩個連結清單在哪個address相遇,找出這個位置。

如果兩個連結清單沒有相遇,那麼輸出-1

注意

Address是5位數,輸出的時候要輸出前導0,使用%05d 格式化輸出。

#include <iostream>
using namespace std;
struct node{
	char data;
	int next;
	bool flag;
}Node[100001];
int main()
{
	int s1,s2,N;
	cin>>s1>>s2>>N;
	for(int i=0;i<N;i++)
	{
		int adr,Next;
		char d;
		scanf("%d %c %d",&adr,&d,&Next);
		Node[adr].data=d;
		Node[adr].next=Next;
		Node[adr].flag=false;
	}
	while(s1!=-1)
	{
		Node[s1].flag=true;
		s1=Node[s1].next;
	}
	while(!Node[s2].flag&&s2!=-1)
	{
		s2=Node[s2].next;
	}
	if(s2==-1)
	{
		printf("-1\n");
		return 0;
	}		
	printf("%05d\n",s2);
	return 0;
}