天天看點

hdu 1712 ACboy needs your help (分組背包) Problem H

Problem H

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 7   Accepted Submission(s) : 4

Problem Description ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?  

Input The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. N = 0 and M = 0 ends the input.  

Output For each data set, your program should output a line which contains the number of the max profit ACboy will gain.  

Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

        

Sample Output

3
4
6

        
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXM=100+5;
const int MAXN=100+5;
int data[MAXN][MAXM];
int f[MAXM];

int main()
{
	int n,m,i,j,k;
	while(cin>>n>>m,m||n)
	{
		memset(f,0,sizeof(f));
		for(i=1;i<=n;i++)
			for(j=1;j<=m;j++)
				scanf("%d",&data[i][j]);
		for(i=1;i<=n;i++)
			for(j=m;j>=0;j--)
				for(k=1;k<=j;k++)
					if(f[j]<f[j-k]+data[i][k])f[j]=f[j-k]+data[i][k];
		printf("%d\n",f[m]);
	}
	return 0;
}