Time Zone
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2849 Accepted Submission(s): 902
Problem Description
Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.
Input
There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9).
Output
For each test, output the time in the format of hh:mm (24-hour clock).
Sample Input
3 11 11 UTC+8 11 12 UTC+9 11 23 UTC+0
Sample Output
11:11 12:12 03:23
Source
2018 Multi-University Training Contest 1
Recommend
liuyiding | We have carefully selected several similar problems for you: 6343 6342 6341 6340 6339
Statistic | Submit | Discuss | Note
心得:輸入的格式要注意,按照題目中的來。
将第8時區時間化為分鐘,求要到達的時區和第8時區之間的內插補點,再加上原來第八時區的時間
注意,‘+’還是‘-’,‘-’的話要最後變為正數。
#include<bits/stdc++.h>
using namespace std;
int main(void)
{
int h,m,t;
double d;
char ch;
int t1,t2,tp;
while(~scanf("%d",&t))
{
while(t--)
{
scanf("%d %d UTC%c%lf",&h,&m,&ch,&d);
t1=h*60+m;
tp=(int)(d*10);
if(ch=='+')
{
t2=t1+tp*6-8*60;
}
else if(ch=='-')
{
t2=t1-tp*6-8*60;
}
t2=t2%(24*60);
if(t2<0) t2+=24*60;
h=t2/60;
m=t2%60;
printf("%02d:%02d\n",h,m);
}
}
return 0;
}