天天看點

HDU 1370-Biorhythms + 中國剩餘定理1:HDU-13702:中國剩餘定理的推導

本文分為兩個部分:1、HDU1370題解,2、中國剩餘定理的推導。

目錄:

1:HDU-1370

2:中國剩餘定理的推導

1:HDU-1370

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6122    Accepted Submission(s): 2384

Problem Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 

Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1. 

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1. 

Sample Input

1

0 0 0 0

0 0 0 100

5 20 34 325

4 5 6 7

283 102 23 320

203 301 203 40

-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.

Case 2: the next triple peak occurs in 21152 days.

Case 3: the next triple peak occurs in 19575 days.

Case 4: the next triple peak occurs in 16994 days.

Case 5: the next triple peak occurs in 8910 days.

Case 6: the next triple peak occurs in 10789 days.

Source

East Central North America 1999; Pacific Northwest 1999

題意:

給你p,e,i,d 4個整數,已知(n+d)%23=p; (n+d)%28=e; (n+d)%33=i ,讓你求出n的最小整數解

題解:

已知:

HDU 1370-Biorhythms + 中國剩餘定理1:HDU-13702:中國剩餘定理的推導
HDU 1370-Biorhythms + 中國剩餘定理1:HDU-13702:中國剩餘定理的推導
HDU 1370-Biorhythms + 中國剩餘定理1:HDU-13702:中國剩餘定理的推導
HDU 1370-Biorhythms + 中國剩餘定理1:HDU-13702:中國剩餘定理的推導

代碼:

#include<string>
#include<cstring>
#include<vector>
#include<map>
#include<cstdio>
#include<ctime>
#include<iostream>
#include<algorithm>
#include<map>
#include<cmath>
typedef long long ll;
using namespace std;
const ll mod=21252;
ll N;
ll p,e,i,d,x,y,z;
ll T,a,b;
ll gcd(ll a,ll b)
{
    return b==0?a:gcd(b,a%b);
}
void findd()
{
    ll i;
    //求X
    for(i=1,N=28*33;; ++i)
    {
        if(i*N%23==1)
            break;
    }
    x=N*i;

    //求y
    for(i=1,N=23*33;; i++)
    {
        if(i*N%28==1)
            break;
    }
    y=N*i;

    //求z
    for(i=1,N=23*28;; ++i)
    {
        if(i*N%33==1)
            break;
    }
    z=N*i;

    N=23*28*33;
    return ;
}
int main()
{
    findd();
    cin>>T;
    bool flag=false;
    while(T--)
    {
        int number=1;
        getchar();
        if(flag) printf("\n");
        while(~scanf("%lld%lld%lld%lld",&p,&e,&i,&d))
        {
            if(p==-1&&e==-1&&i==-1&&d==-1)
                break;
            ll puts=(x*p+y*e+z*i)%N-d;
            puts=(puts+mod-1)%mod+1;
            printf("Case %d: the next triple peak occurs in %lld days.\n",number++,puts);
        }
        flag=true;
    }
    return 0;
}
           

2:中國剩餘定理的推導

首先呢,從一個民間傳說開始。

淮安民間傳說着一則故事——“韓信點兵”,其次有成語“韓信點兵,多多益善”。韓信帶1500名兵士打仗,戰死四五百人,站3人一排,多出2人;站5人一排,多出4人;站7人一排,多出6人。韓信很快說出人數:1049。

上面這段話的意思就是:(其中n代表的是總人數)

n%3=2
n%5=4
n%7=6
           

由于資料較小,我們可以直接使用枚舉的方法求出答案,可是如果說資料很大我們不能采用暴力的方法,又該怎麼辦呢?

這個時候中國剩餘定理就來了。。。

HDU 1370-Biorhythms + 中國剩餘定理1:HDU-13702:中國剩餘定理的推導

70*a%3=2并且70*a%5=0,70*a%7=0

同理,我們可以得到b=1,c=1,他們對應的值分别為21和15

n=(70*2+21*3+15*2)%lcm(3,5,7)=23

也就是我們要求一個數num1,就比如5*7*a%3=1得到的70,對于這個70,它對5和7進行取餘後結果都是0

再讓這個num1*2(注意,前面出現的是n%3=2,因為我們得到的num1是基于num1%3=1的基礎之上的)

接下來(num1*2+num2*3+num3=2)%lcm(3,5,7)=總人數

總結起來就是分為三步:(對于上面的資料來說)

1:求num1,num2,num3......

2:計算num=(num1*餘數1+num2*餘數2+num3*餘數3......)

3:   計算num%lcm(取餘數1,,取餘數2,..........)