天天看點

【貪心/線性DP】Monkey and Banana(HDU-1069)【線性DP】Monkey and Banana(HDU-1069)

【線性DP】Monkey and Banana(HDU-1069)

題目連結

題目

Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
           

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
           

思路

機翻題目

一組研究人員正在設計一個實驗,以測試猴子的智商。他們将在建築物的屋頂上懸挂一根香蕉,同時為猴子提供一些障礙。如果猴子足夠聰明,則可以通過将一個塊放在另一個塊上來建造塔,然後爬上去以獲得最喜歡的食物,進而到達香蕉。

研究人員擁有n種類型的積木,每種類型的積木數量不受限制。每個i型塊都是具有線性尺寸(xi,yi,zi)的矩形實體。可以重新調整塊的方向,以便使其三個尺寸中的任意兩個确定底座的尺寸,另一個尺寸是高度。

他們希望通過堆疊磚塊確定最高的塔可以到達屋頂。問題是,在建造大廈時,一個塊隻能放置在另一個塊的頂部,隻要上部塊的兩個基本尺寸都嚴格小于下部塊的相應基本尺寸,因為必須給猴子一些空間。例如,這意味着不能堆疊定向為具有相等大小的底部的塊。

您的工作是編寫一個程式,該程式确定猴子可以使用給定的一組積木建造的最高塔的高度。

大概是

貪心排序+LIS問題

回憶一下基本的LIS問題,序列順序是确定的,這題看起來不确定順序,實際上可以通過貪心的方式來排序,我們隻需要先排面積然後排長度即可得到固定的順序,這樣問題轉化成LIS問題。

代碼

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
ll n,C,ans;
const int N=1e3+10;
struct Cube
{
    ll x,y,z,s;
}F[N];
ll dp[N];
bool cmp(Cube a,Cube b)
{
    if(a.s!=b.s)return a.s>b.s;
    if(a.y!=b.y)return a.y>b.y;
    if(a.x!=b.x)return a.x>b.x;
}
int main()
{
    while(~scanf("%lld",&n)&&n)
    {
        memset(dp,0,sizeof dp);
        int cnt=0;
        for(int i=1;i<=n;i++)
        {
            ll a,b,c;
            scanf("%lld%lld%lld",&a,&b,&c);
            if(a>b)swap(a,b);
            if(a>c)swap(a,c);
            if(b>c)swap(b,c);
            F[cnt+1]={a,b,c,a*b};
            F[cnt+2]={a,c,b,a*c};
            F[cnt+3]={b,c,a,b*c};
            F[cnt+4]={b,a,c,b*a};
            F[cnt+5]={c,a,b,a*c};
            F[cnt+6]={c,b,a,b*c};
            cnt+=6;
        }
        sort(F+1,F+1+cnt,cmp);
        for(int i=1;i<=cnt;i++)dp[i]=F[i].z;
        for(int i=1;i<=cnt;i++)
        {
            for(int j=1;j<i;j++)
            {
                if(F[i].x<F[j].x&&F[i].y<F[j].y)dp[i]=max(dp[i],dp[j]+F[i].z);
            }
        }
        ll ans=0;
        for(int i=1;i<=cnt;i++)ans=max(ans,dp[i]);//不是dp[n]啊
        C++;
        printf("Case %lld: maximum height = %lld\n",C,ans);
    }
    return 0;
}
           

繼續閱讀