天天看點

HDU 4006 The kth great number 【優先隊列求第K大數】The kth great number

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 7004    Accepted Submission(s): 2857

Problem Description Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.  

Input There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q
        

Sample Output

1
2
3


        
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;
priority_queue<int,vector<int>,greater<int> >q;
int main()
{
    int n,k,x;
    char c;
    while(scanf("%d %d",&n,&k)!=EOF)
    {
        while(!q.empty()) q.pop();
        while(n--)
        {
            getchar();
            scanf("%c",&c);
            if(c=='I')
            {
                scanf("%d",&x);
                q.push(x);
            }
            while(q.size()>k) q.pop();
            if(c=='Q')
            {
                printf("%d\n",q.top());
            }
        }
    }
    return 0;
}
           

繼續閱讀