天天看點

hdu 1548 A strange liftA strange lift

A strange lift

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7965    Accepted Submission(s): 3002

Problem Description There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?

Input The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.

A single 0 indicate the end of the input.  

Output For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".  

Sample Input

5 1 5
3 3 1 2 5
0
        

Sample Output

3
        

Recommend 8600  

題目大意。有一個奇怪的電梯。每層樓會給出一個數字ki由題目給出。你隻能上ki樓或下ki樓。當然不能超過樓層的限制。上天入地是不行滴。

問從A到B層最少按多少次按鈕

#include <stdio.h>
#include<string.h>

int maps[250][250],dis[250],ok[250];//點下的單源最短路要的東西
int n;
int INF=100000000;
void dijk()
{
    int i,t,p,mi;

    t=n;
    while(t--)
    {
        mi=INF;
        for(i=1; i<=n; i++)
        {
            if(mi>dis[i]&&!ok[i])
            {
                mi=dis[i];
                p=i;
            }
        }
        ok[p]=1;
        for(i=1; i<=n; i++)
        {
            if(!ok[i]&&maps[p][i]+dis[p]<dis[i])
                dis[i]=maps[p][i]+dis[p];
        }
    }
}
int main()
{
    int i,j,a,b,d,up,down;

    while(scanf("%d",&n),n)
    {
        memset(ok,0,sizeof ok);
        scanf("%d%d",&a,&b);
        for(i=1; i<=n; i++)//必要的初始化
        {
            dis[i]=INF;
            for(j=1; j<=n; j++)
            {
                if(i==j)
                    maps[i][j]=0;
                maps[i][j]=INF;
            }
        }
        for(i=1; i<=n; i++)
        {
            scanf("%d",&d);
            up=i+d;//記錄兩層樓是否相通
            down=i-d;
            if(up<=n)
                maps[i][up]=1;//相通的話按一下就行了
            if(down>=1)
                maps[i][down]=1;
        }
        dis[a]=0;
        dijk();
        if(dis[b]!=INF)
            printf("%d\n",dis[b]);
        else
            printf("-1\n");
    }
    return 0;
}
           

繼續閱讀