天天看點

hdu 3006 The Number of set(位運算)                                                      The Number of set

                                                      The Number of set

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 956    Accepted Submission(s): 594

Problem Description Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.  

Input There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.  

Output For each case,the output contain only one integer,the number of the different sets you get.  

Sample Input

4 4
1 1
1 2
1 3
1 4
2 4
3 1 2 3
4 1 2 3 4
        

Sample Output

15
2
        

Source 2009 Multi-University Training Contest 11 - Host by HRBEU  

Recommend gaojie

題意:k個數算一個集合,n個集合,集合中的數最大不大于m(m小于等于14) 題解:位運算....挺好用的啊啊啊啊啊啊啊啊啊啊啊啊,用一個位代表一個是否已取,1代表已取,0則反之,共用14個位的數就可以代表一個集合~~~

#include<stdio.h>
#include<string.h>
int cc[1<<15];
int main()
{
    int temp,c,MAX,cou,i,n,m,k;

    while(scanf("%d%d",&n,&m)>0)
    {
        memset(cc,0,sizeof(cc));
        while(n--)
        {
            temp=0;
            scanf("%d",&k);
            while(k--)
            {
                scanf("%d",&c);
                temp=temp|(1<<(c-1));
            }
            cc[temp]=1;
            for(MAX=1<<m,i=0;i<=MAX;i++)
            {
                if(cc[i]) cc[temp|i]=1;
            }
        }
        for(cou=i=0;i<=MAX;i++)
            if(cc[i]) cou++;
        printf("%d\n",cou);
    }

    return 0;
}