天天看點

hdu1159 Common Subsequence (最長公共子序列) Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 29565    Accepted Submission(s): 13314

Problem Description A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest 
abcd mnp
        

Sample Output

4
2
0
        

Source Southeastern Europe 2003  

Recommend Ignatius   |   We have carefully selected several similar problems for you:   1069  1257  1203  2602  1978   

代碼:

#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

const int maxn=1e4;
char a[maxn+10],b[maxn+10];
int f[maxn][maxn];

int main()
{
 // freopen("1.in","r",stdin);
  int n,m,i,j;
  while(scanf("%s%s",&a[1],&b[1])!=EOF)
    {
      a[0]=b[0]='a',n=strlen(a),m=strlen(b);
      for(i=1;i<n;i++)
        for(j=1;j<m;j++)
          if(a[i]==b[j])f[i][j]=f[i-1][j-1]+1;
          else f[i][j]=max(f[i][j-1],f[i-1][j]);
	  printf("%d\n",f[n-1][m-1]);
	}
  return 0;
}
           

繼續閱讀