天天看點

uva 572 Oil Deposits(DFS周遊圖) Oil Deposits 

Oil Deposits 

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing  m  and  n , the number of rows and columns in the grid, separated by a single space. If  m  = 0 it signals the end of the input; otherwise 

uva 572 Oil Deposits(DFS周遊圖) Oil Deposits 

 and 

uva 572 Oil Deposits(DFS周遊圖) Oil Deposits 

. Following this are  m  lines of  n  characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ` * ', representing the absence of oil, or ` @ ', representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
      

Sample Output 

0
1
2
2      

題目大意:‘@’代表油田,判斷給出途中有多少塊油田(注意相連的是同一塊,相連是八個方向)

解題思路:周遊,碰到‘@’就講該位置和跟它相鄰的‘@’全變成' * ',相當于采集掉了(防止重複計算)。

#include<stdio.h>
#include<string.h>
#define N 105
char map[N][N];
int n, m, cnt;
const int dir[8][2] = {{-1, -1}, {-1, 0}, {-1, 1}, {0, -1}, {0, 1}, {1, -1}, {1, 0}, {1, 1}};
void DFS(int a, int b){

	map[a][b] = '*';
	for (int i = 0; i < 8; i++){
		if (a + dir[i][0] < 0 || a + dir[i][0] >= n)	continue;
		if (b + dir[i][1] < 0 || b + dir[i][1] >= m)	continue;
		if (map[a + dir[i][0]][b + dir[i][1]] == '*')	continue;
		DFS(a + dir[i][0], b + dir[i][1]);
	}
}

int main(){
	while (scanf("%d%d%*c", &n, &m), n && m){
		// Init.
		memset(map, 0, sizeof(map));
		cnt = 0;

		// Read.
		for (int i = 0; i < n; i++)
			gets(map[i]);

		// Handle.
		for (int i = 0; i < n; i ++){
			for (int j = 0; j < m; j++){
				if (map[i][j] == '@'){
					DFS(i, j);
					cnt++;
				}
			}
		}

		printf("%d\n", cnt);
	}
	return 0;}