第一次用java寫acm程式
HDU1000
http://acm.hdu.edu.cn/showproblem.php?pid=1000
A + B Problem
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 154095 Accepted Submission(s): 48841
Problem Description Calculate A + B.
Input Each line will contain two integers A and B. Process to end of file.
Output For each case, output A + B in one line.
Sample Input
1 1
Sample Output
2
Author HDOJ
代碼如下:
import java.util.Scanner;
public class Main
{
public static void main(String args[])
{
int a,b;
Scanner keyIn = new Scanner(System.in);
while(keyIn.hasNext())
{
a = keyIn.nextInt();
b = keyIn.nextInt();
System.out.println(a+b);
}
}
}
這裡第一次用java玩acm的注意:
1,主類所在類的類名一定是Main,即是main方法所在類
2,循環輸入的問題,在C++我們可以用while(scanf("%d",&a)!=EOF),但是在java中我們用的是 掃描類的hasNext()函數來判斷是否結束輸入,另外注意導入Scanner類