天天看點

poj3694Network

Network

Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 11215 Accepted: 4152

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).

Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.

The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.

The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0      

Sample Output

Case 1:
1
0

Case 2:
2
0      

題意:一個網絡管理者管理一個網絡,網絡中的電腦直接或間接的相連接配接,管理者有Q次操作,每次向網絡中建立一條新邊,向管理者報告橋的個數。

思路:我們先用tarjan算法将橋和強連通分支先求出來,如果新加的邊在一個分支裡,不影響橋的數量,如果在不同的分支裡,相當于在樹中加了一條邊,在這兩點到公共祖先的橋全部減去。

代碼:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int N=200000+10;
struct node
{
    int v,next;
}e[N<<2];
int head[N<<2];
int dfn[N<<2];
int low[N<<2];
int pre[N];
bool is[N];
int d[N];
int num;
int cnt;
int ans;
void init()
{
    memset(head,-1,sizeof(head));
    memset(low,-1,sizeof(low));
    memset(dfn,-1,sizeof(dfn));
    memset(d,0,sizeof(d));
    memset(is,false,sizeof(is));
    ans=num=cnt=0;
}
void addedge(int u,int v)
{
    e[num].v=v;
    e[num].next=head[u];
    head[u]=num++;
}
int LCA(int a,int b)
{
    if(d[a]>d[b])swap(a,b);
    while(d[a]<d[b])
    {
        if(is[b])
        {
            ans--;
            is[b]=false;
        }
        b=pre[b];
    }
    while(a!=b)
    {
        if(is[a])ans--;
        if(is[b])ans--;
        is[a]=is[b]=false;
        a=pre[a],b=pre[b];
    }
    return ans;
}
void tarjan(int u)
{
    dfn[u]=low[u]=++cnt;
    d[u]=d[pre[u]]+1;
    for(int i=head[u];i!=-1;i=e[i].next)
    {
        int v=e[i].v;
        if(dfn[v]==-1)
        {
            pre[v]=u;
            tarjan(v);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u])
            {
                ans++;
                is[v]=true;
            }
        }
        else if(v!=pre[u])low[u]=min(low[u],dfn[v]);

    }
}
int main()
{
    int n,m;
    int k=0;
    while(~scanf("%d%d",&m,&n)&&m+n)
    {
        int i;
        int u,v;
        init();
        for(i=0;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            addedge(u,v);
            addedge(v,u);
        }
        pre[1]=1;
        tarjan(1);
       
        int q;
        scanf("%d",&q);
        printf("Case %d:\n",++k);
        while(q--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            printf("%d\n",LCA(x,y));
        }
        printf("\n");
    }
    return 0;
}
           
LCA