天天看點

杭電ACM HDU 3346 Lucky NumberLucky Number

Lucky Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1523    Accepted Submission(s): 800

Problem Description To Chinese people, 8 is a lucky number. Now your task is to judge if a number is lucky.

We say a number is lucky if it’s a multiple of 8, or the sum of digits that make up the number is a multiple of 8, or the sum of every digit’s square is a multiple of 8.

Input The first line contains an integer stands for the number of test cases.

Each test case contains an integer n (n >= 0).

Output For each case, output “Lucky number!” if the number is lucky, otherwise output “What a pity!”.

Sample Input

2
0
8
        

Sample Output

Lucky number!
Lucky number!
        

Author dandelion

Source HDU2010省賽集訓隊選拔賽(校内賽)

Recommend lcy

#include<cstdio>
int main(){
    int t,n,s1,s2;
    scanf("%d",&t);
    while(t--){
        scanf("%D",&n);
        if(n%8==0){
            printf("Lucky number!\n");
            continue;
        }
        for(s1=s2=0;n;){
            s1+=n%10;
            s2+=(n%10)*(n%10);
            n/=10;
        }
        if(s1%8==0||s2%8==0){
            printf("Lucky number!\n");
            continue;
        }
        printf("What a pity!\n");
    }
}