天天看點

POJ 1016 Numbers That Count(字元串處理)

Numbers That Count

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 15752 Accepted: 5160

Description

"Kronecker's Knumbers" is a little company that manufactures plastic digits for use in signs (theater marquees, gas station price displays, and so on). The owner and sole employee, Klyde Kronecker, keeps track of how many digits of each type he has used by maintaining an inventory book. For instance, if he has just made a sign containing the telephone number "5553141", he'll write down the number "5553141" in one column of his book, and in the next column he'll list how many of each digit he used: two 1s, one 3, one 4, and three 5s. (Digits that don't get used don't appear in the inventory.) He writes the inventory in condensed form, like this: "21131435". 

The other day, Klyde filled an order for the number 31123314 and was amazed to discover that the inventory of this number is the same as the number---it has three 1s, one 2, three 3s, and one 4! He calls this an example of a "self-inventorying number", and now he wants to find out which numbers are self-inventorying, or lead to a self-inventorying number through iterated application of the inventorying operation described below. You have been hired to help him in his investigations. 

Given any non-negative integer n, its inventory is another integer consisting of a concatenation of integers c1 d1 c2 d2 ... ck dk , where each ci and di is an unsigned integer, every ci is positive, the di satisfy 0<=d1<d2<...<dk<=9, and, for each digit d that appears anywhere in n, d equals di for some i and d occurs exactly ci times in the decimal representation of n. For instance, to compute the inventory of 5553141 we set c1 = 2, d1 = 1, c2 = 1, d2 = 3, etc., giving 21131435. The number 1000000000000 has inventory 12011 ("twelve 0s, one 1"). 

An integer n is called self-inventorying if n equals its inventory. It is called self-inventorying after j steps (j>=1) if j is the smallest number such that the value of the j-th iterative application of the inventory function is self-inventorying. For instance, 21221314 is self-inventorying after 2 steps, since the inventory of 21221314 is 31321314, the inventory of 31321314 is 31123314, and 31123314 is self-inventorying. 

Finally, n enters an inventory loop of length k (k>=2) if k is the smallest number such that for some integer j (j>=0), the value of the j-th iterative application of the inventory function is the same as the value of the (j + k)-th iterative application. For instance, 314213241519 enters an inventory loop of length 2, since the inventory of 314213241519 is 412223241519 and the inventory of 412223241519 is 314213241519, the original number (we have j = 0 in this case). 

Write a program that will read a sequence of non-negative integers and, for each input value, state whether it is self-inventorying, self-inventorying after j steps, enters an inventory loop of length k, or has none of these properties after 15 iterative applications of the inventory function.

Input

A sequence of non-negative integers, each having at most 80 digits, followed by the terminating value -1. There are no extra leading zeros.

Output

For each non-negative input value n, output the appropriate choice from among the following messages (where n is the input value, j is a positive integer, and k is a positive integer greater than 1): 

n is self-inventorying 

n is self-inventorying after j steps 

n enters an inventory loop of length k 

n can not be classified after 15 iterations

Sample Input

22 
31123314 
314213241519 
21221314 
111222234459 
-1      

Sample Output

22 is self-inventorying 
31123314 is self-inventorying 
314213241519 enters an inventory loop of length 2 
21221314 is self-inventorying after 2 steps 
111222234459 enters an inventory loop of length 2       

Source

East Central North America 1998

題目要求将數n按一定規則進行轉換,比如:1231560,這個數字中有1個0、2個1、1個2、1個3、1個5、1個6,則,其轉換後的下一個數字為102112131516,接下去再對這個數字進行轉換。

在15次轉換之内,可能會發生以下四種情況:m是輸入值,j是一個正整數,k是一個大于1的正整數。

(1)數字n經過轉換一次後,仍為數字n,如:22

這種情況下輸出:n is self-inventorying

(2)數字n經過j次轉換之後的數字m,的下一次轉換結果仍為m,如:21221314

這種情況下輸出:n is self-inventorying after j steps 

(3)數字n經過i次轉換後的值與其第j次轉換相同,進入了一個k = i - j的循環,如:314213241519

這種情況下輸出:n enters an inventory loop of length k 

(4)數字n在15次轉換之内均沒有和之前的情況相同,如:99999999999999999999999...999999999(80個9)

這種情況下輸出:n can not be classified after 15 iterations

這道題的算法并不難,思路也比較簡單,我因為控制循環的次數出錯,讓字元串隻轉換了14次而不是15次,是以WA了3次,解題方法按照上面的解釋應該就可以解出來。貼代碼:

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <map>
#include <string>

using namespace std;
map<string, int> StrInt;
char next[200];
char turn[200];
char str[200];

string change(string str){
    int num[10];
    int i, j, k;
    string result;

    memset(num, 0, sizeof(num));
    for (i = 0; i < str.length(); i++){
        num[str[i] - '0']++;
    }
    for (i = j = 0; i < 10; i++){
        if (num[i] != 0){
            memset(turn, 0, sizeof(turn));
            k = 0;
            do {
                turn[k++] = (num[i] % 10);
                num[i] /= 10;
            }while(num[i] != 0);
            for (k = k - 1; k >= 0; k--){
                next[j++] = '0' + turn[k];
            }
            next[j++] = '0' + i;
        }
    }
    next[j] = '\0';
    result = next;
    return result;
}


int main(void){
    int n;
    string atStr;
    int i, j, end;
    int flag = 0;

    while (scanf("%s", str), strcmp(str, "-1") != 0){
        StrInt.clear();
        atStr = str;
        flag = 0;
        for (i = 0; i < 16; i++){
            if (StrInt.count(atStr) == 0){
                StrInt[atStr] = i;
            }
            else{
                j = StrInt[atStr];
                if (i == 1 && j == 0){
                    flag = 1;
                    printf("%s is self-inventorying\n", str);
                }
                else if (j == i - 1){
                    flag = 2;
                    end = j;
                    printf("%s is self-inventorying after %d steps\n", str, end);
                }
                else{
                    flag = 3;
                    end = i - j;
                    printf("%s enters an inventory loop of length %d\n", str, end);
                }
                break;
            }
            atStr = change(atStr);
        }
        if (flag == 0){
            printf("%s can not be classified after 15 iterations\n", str);
        }
    }
    return 0;
}
           

繼續閱讀