天天看點

HDU 1570 A C (數學題)

A C

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4786    Accepted Submission(s): 3077

Problem Description

Are you excited when you see the title "AC" ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.

HDU 1570 A C (數學題)

Now I will give you n and m , and your task is to calculate the answer .

Input

In the first line , there is a integer T indicates the number of test cases.

Then T cases follows in the T lines.

Each case contains a character 'A' or 'C', two integers represent n and m. (1<=n,m<=10)

Output

For each case , if the character is 'A' , calculate A(m,n),and if the character is 'C' , calculate C(m,n).

And print the answer in a single line.

Sample Input

2A 10 10
C 4 2      

Sample Output

36288006      

Author

linle

Source

​​HDU 2007-1 Programming Contest ​​

AC代碼:

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;

int main()
{
  int a;
  cin>>a;
  while(a--)
  {
    char x;
    int m(0),n(0),sum;
    cin>>x;
    cin>>n>>m;
    sum=1;
    for(int i=n;i>n-m;i--)
    {
      sum=sum*i;
    }
      if(x=='A') 
    cout<<sum<<endl;
    if(x=='C') 
    {
      int num=1;
      for(int j=m;j>0;j--)
      {
        num=num*j;
      }
      cout<<sum/num<<endl;
    }
  }

  return 0; 
}