天天看點

POJ 3694 Network (求割邊 + LCA)

這道題是一個無向圖,詢問加入某條邊後,問圖内剩餘的橋有多少。

這題的大概思路就是,先求割邊并标記,然後縮點,形成一棵樹,然後把這顆樹上各個結點的父結點用dfs求出來,再然後就是LCA了,因為加入某條邊後,樹内會形成一個圈,這個圈上所有的邊将不再是橋,可以發現跟LCA的關聯。

求LCA用裸的方法就行,比較直覺些,也好操作。

實際上,這道題也不一定要縮點,如果用縮點的思路來做的話,程式将十分麻煩。可以直接根據dfn值來進行LCA。因為,我們觀察low[v] > dfn[u]這個條件,代表的意思就是v無法通過回邊或者通過子女到達比u點更靠前的點,那麼我們隻需要标記v點即可表明割邊。在進行LCA時,由于樹的組成就是原圖中的割邊,是以在原圖中,根據這個标記來判斷是否将割邊被轉化為了普通邊。

Network
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7040 Accepted: 2521

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).

Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.

The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.

The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computerA and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0      
Sample Output
Case 1:
1
0

Case 2:
2
0      

Source

2008 Asia Hefei Regional Contest Online by USTC

[Submit]   [Go Back]   [Status]   [Discuss]

/*
ID:huang_l1
LANG:C++
PROG:combo
*/
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
#define prt(k) cout<<#k" = "<<k<<endl;
const int N = 100005;
int head[N], n, m, Q, dep[N], len[N]; /// len[i] 表示 i 到根距離
struct Edge
{
    int to, next, w;
}e[N << 1];
int f[N][22];
int mm;
void add(int u, int v, int w=1)
{
    e[mm] = (Edge){v, head[u], w};
    head[u] = mm++;
}
int cur, cnt;
int dfn[N], low[N], bridge[N], p[N], fa[N];
///p[i] -- i 的父親
///bridge[i] -- (i, p[i]) 這條邊是不是割邊
int find(int x) { return x==fa[x]? x : fa[x]=find(fa[x]); }
void init()
{
    mm = cur = 0;
    memset(head, -1, sizeof head);
    for (int i=1;i<=n;i++) fa[i]=i;
    memset(dfn, 0, sizeof dfn);
    dep[0] = 0;
    memset(bridge, 0, sizeof bridge);

}
void dfs(int u, int fa)
{
    dfn[u] = low[u] = ++cur;
    dep[u] = dep[p[u]] + 1;
    for (int i=head[u]; ~i; i=e[i].next)
    {
        int v = e[i].to;
        if (v == fa) continue;
        if (dfn[v] == 0) {
            p[v] = u;
            dfs(v, u);
            low[u] = min(low[u], low[v]);
            if (low[v] > dfn[u] ) {
                cnt ++;
                bridge[v] = 1;
            }
        }
        else low[u] = min(low[u], dfn[v]);
    }
}
void LCA(int u, int v)
{
    if (dep[u] < dep[v]) swap(u, v);
    while (dep[u] > dep[v]) {
        if (bridge[u]) cnt--, bridge[u] = 0;
        u = p[u];
    }
    while (u - v) {
        if (bridge[u]) cnt--, bridge[u] = 0;
        if (bridge[v]) cnt--, bridge[v] = 0;
        u = p[u], v = p[v];
    }
}
int main()
{
    int ca = 1;
    while (scanf("%d%d", &n, &m) != EOF && n) {
        init();
        for (int i=0;i<m;i++) {
            int u, v;
            scanf("%d%d", &u, &v);
            add(u, v); add(v, u);
        }
        dfs(1, 0);
      /**  for (int i=1;i<=n;i++) {
            printf("dep[%d]=%d ",i,dep[i]);
            printf("p[%d]=%d ", i, p[i]);
            printf("bridge[%d]=%d\n", i, bridge[i]);
        } */
        scanf("%d", &Q);
        printf("Case %d:\n", ca++);
        for (int i=0;i<Q;i++) {
            int u, v;
            scanf("%d%d", &u, &v);
            LCA(u, v);
            printf("%d\n", cnt);
        }
        putchar(10);
    }
    return 0;
}
           

繼續閱讀