天天看點

POJ1018Communication System題解動态規劃DP

Communication System

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12607 Accepted: 4377

Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.

By overall bandwidth (B) we mean the minimum of the bandwidths of the chosen devices in the communication system and the total price (P) is the sum of the prices of all chosen devices. Our goal is to choose a manufacturer for each device to maximize B/P.

Input

The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by the input data for each test case. Each test case starts with a line containing a single integer n (1 ≤ n ≤ 100), the number of devices in the communication system, followed by n lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi (1 ≤ mi ≤ 100), the number of manufacturers for the i-th device, followed by mi pairs of positive integers in the same line, each indicating the bandwidth and the price of the device respectively, corresponding to a manufacturer.

Output

Your program should produce a single line for each test case containing a single number which is the maximum possible B/P for the test case. Round the numbers in the output to 3 digits after decimal point.

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110      

Sample Output

0.649      

Source

Tehran 2002, First Iran Nationwide Internet Programming Contest 狀态: 設d[i][j]表示前i組帶寬為j時的最小價格 狀态轉移方程: d[i][j]=min{d[i-1][j]+p[i][k]};   (b[i][k]>=j) ans=max{j/d[n][j]} j枚舉到400 代碼: #include<cstdio>

int main()

{

int t,n,w[105][105],v[105][105],x,i,j,k;

scanf("%d",&t);

while(t--)

{

int d[105][405]={0};

double s=0;

scanf("%d",&n);

for(i=1;i<=n;i++)

{

scanf("%d",&x);

for(j=0;j<x;j++)

scanf("%d%d",&w[i][j],&v[i][j]);

for(j=0;j<=400;j++)

{

int m=1<<30;

for(k=0;k<x;k++)

if(j<=w[i][k]&&d[i-1][j]+v[i][k]<m)

m=d[i-1][j]+v[i][k];

d[i][j]=m;

}

}

for(j=1;j<=400;j++)

if(j/(double)d[n][j]>s)

s=j/(double)d[n][j];

printf("%.3f/n",s);

}

}

繼續閱讀