天天看點

hdu 5086(遞推)

Revenge of Segment Tree

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1541    Accepted Submission(s): 552

Problem Description

In

computer science, a segment tree is a tree data structure for storing

intervals, or segments. It allows querying which of the stored segments

contain a given point. It is, in principle, a static structure; that is,

its content cannot be modified once the structure is built. A similar

data structure is the interval tree.

A segment tree for a set I of n

intervals uses O(n log n) storage and can be built in O(n log n) time.

Segment trees support searching for all the intervals that contain a

query point in O(log n + k), k being the number of retrieved intervals

or segments.

---Wikipedia

Today, Segment Tree takes revenge on

you. As Segment Tree can answer the sum query of a interval sequence

easily, your task is calculating the sum of the sum of all continuous

sub-sequences of a given number sequence.

Input

The first line contains a single integer T, indicating the number of test cases.

Each

test case begins with an integer N, indicating the length of the

sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]

1. 1 <= T <= 10

2. 1 <= N <= 447 000

3. 0 <= Ai <= 1 000 000 000

Output

For each test case, output the answer mod 1 000 000 007.

Sample Input

2

1

3

1 2 3

Sample Output

20

Hint

For the second test case, all continuous sub-sequences are [1], [2], [3], [1, 2], [2, 3] and [1, 2, 3]. So the sum of the sum of the sub-sequences is 1 + 2 + 3 + 3 + 5 + 6 = 20.

Huge input, faster I/O method is recommended. And as N is rather big, too straightforward algorithm (for example, O(N^2)) will lead Time Limit Exceeded.

And one more little helpful hint, be careful about the overflow of int.

Source

BestCoder Round #16

題意:求一個序列所有的連續子序列之和。

題解:假設序列為 1 2 3

那麼合法序列有:

1 第一項

1 2 第二項

1 2 3 第三項

2 3

dp[i]代表第i項 那麼我們可以看出 dp[i] = dp[i-1]+i*a[i]

最終答案累加即可。

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include <algorithm>
#include <string.h>
using namespace std;
typedef long long LL;
const int mod = 1000000007;
const int N = 447005;
int n;
LL a[N];
LL dp[N];
int main()
{

    int tcase;
    scanf("%d",&tcase);
    while(tcase--){
        scanf("%d",&n);
        for(int i=1;i<=n;i++){
            scanf("%lld",&a[i]);
        }
        dp[1]  = a[1];
        for(int i=2;i<=n;i++){
            dp[i] = (dp[i-1] + (i*a[i])%mod)%mod;
        }
        LL ans = 0;
        for(int i=1;i<=n;i++){
            ans = (ans+dp[i])%mod;
        }
        printf("%lld\n",ans);
    }
    return 0;
}      
上一篇: 遞推算法
下一篇: hdu 5155(遞推)