天天看點

POJ 1753 Flip Game (DFS)

題目連結:POJ 1753

Problem Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwww

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww
           

Sample Output

4
           

Solution

題意

給定 4 * 4 的正方形,每個格子要麼是黑色,要麼是白色,可以改變任意的格子的顔色,其上下左右的格子也會改變,問至少改變幾個格子可以使正方形變為全黑或者全白。

思路

DFS

  1. 每個格子要麼不翻,要麼翻 1 次。(翻奇數次和翻 1 次效果相同,翻偶數次和不翻效果一樣)
  2. 可以選擇翻轉 0 個、1 個、2 個、3 個 ... 16 個
  3. 每次翻完後判斷是否為純色,如果為純色就輸出相應的格子個數,如果 16 個翻轉了還不是純色,就輸出“impossible”。

Code

#include<bits/stdc++.h>
using namespace std;

bool mp[10][10]; //存儲棋子
bool flag; //判斷是否成功
int step; //步數

//判斷目前狀态是否全是白在上或是黑在上
int judge() {
    int i,j;
    for(i = 0; i < 4; ++i) {
        for(j = 0; j < 4; ++j) {
            if(mp[i][j] != mp[0][0]) return 0;
        }
    }
    return 1;
}

//翻轉棋子,同時翻轉四周相鄰的棋子
void flip(int x,int y) {
    mp[x][y] =! mp[x][y];
    if(y <= 2) mp[x][y + 1] =! mp[x][y + 1];
    if(y != 0) mp[x][y - 1] =! mp[x][y - 1];
    if(x <= 2) mp[x + 1][y] =! mp[x + 1][y];
    if(x != 0) mp[x - 1][y] =! mp[x - 1][y];
}

//搜尋
void dfs(int x, int y, int dep) {
	// 搜尋深度與步數相同時就回溯
    if(step == dep) {
        if(judge()) flag = true;
        return;
    }
    // 如果已經滿足條件就可以傳回
    if(flag || x == 4) return;

    //翻轉棋子
    flip(x, y);
    //進行下一狀态的搜尋
    if(y < 3) dfs(x, y + 1, dep + 1);
    else dfs(x + 1, 0, dep + 1);

	//将該棋子再翻回,即目前棋子不翻
    flip(x, y);
    //進行下一狀态的搜尋
    if(y < 3) dfs(x, y + 1, dep);
    else dfs(x + 1, 0, dep);
}

int main() {
    flag = false; //初始化flag為false
    //初始化棋盤每個位置為false
    for(int i = 0; i < 4; ++i) {
        for(int j = 0; j < 4; ++j) {
            mp[i][j] = false;
        }
    }

    //輸入
    for(int i = 0; i < 4; ++i) {
        for(int j = 0; j < 4; ++j) {
            char c;
            scanf("%c", &c);
            if(c == 'b') mp[i][j] = true; //設定b為true
        }
        getchar();
    }

    //對0-16的每個步長進行搜尋
    for(step = 0; step <= 16; step++) {
        dfs(0, 0, 0);
        if(flag) break; //如果成功了,該步長就是最小值
    }

    //成功就輸出步長,失敗就輸出impossible
    if(flag) printf("%d\n", step);
    else printf("Impossible\n");

    return 0;
}

           

繼續閱讀