天天看點

poj-1163-The Triangle

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)      

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5      

Sample Output

30
題目大意:
求從最上面到最下面的最大和;參照Figure 1圖      
#include<iostream>
using namespace std;
int main()
{

   int n,aa[100][100];
   cin>>n;
   for(int i=0;i<n;i++)
    for(int j=0;j<=i;j++)
    cin>>aa[i][j];

    for(int i=n-2;i>=0;i--)//為什麼要n-2呢??
                //思路是從倒數第一行開始把值加到上面一行,這樣得到的aa[0][0]一定是最大值
   {
       for(int j=0;j<=i;j++)
       {
           aa[i][j]+=max(aa[i+1][j],aa[i+1][j+1]);
       }
   }
cout<<aa[0][0]<<endl;


return 0;
}
例如:
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5
執行之後結果:
30
23 8
20 1 0 
7 12 4 4
4 5 2 6 5