天天看点

CSU 1566 The Maze Makers

The Maze Makers is a publisher of puzzle books. One of their most popular series is maze books. They have a program that generates rectangular two-dimensional mazes like the one shown in Figure 1. The rules for these mazes are: (1) A maze has exactly two exterior cell walls missing, opening to two distinct terminal cells, (2) starting from any one cell, all other cells are reachable, (3) between any two cells in the maze there is exactly one simple path. Formally, a path is a sequence of cells where each cell and its successor on the path share an edge without a wall. A simple path is a path that never repeats a cell.

The Maze Maker program uses hexadecimal digits to encode the walls and passages of a maze. For each cell in the maze there is a corresponding hex digit. As shown in Figure 2, the 1's and 0's in the 4 digit binary representation of a hex digit correspond to the walls (1's) and passages (0's) for each cell in the maze. For example, the binary encoding for the hex digit B is 1011. Starting at the top of the cell and moving clockwise around it, this digit represents a cell with a wall at the top, a passage to the right and walls at the bottom and to the left. A path between two maze cells successively moves one cell up, down, left or right, going through passages only.

Figure 1: Sample Maze

Figure 2: Hex Code for Walls and Passageways

Figure 3: Maze with Cell Labels

Figure 3 shows the sample maze with the hexadecimal labels in each cell. For example, the hexadecimal digit E in the top-right cell indicates that it has a wall above it, to its right, below it, yet a passageway to its left. The hexadecimal digit 8 to its left indicates that its cell has only a wall above it. The inputs will always be self-consistent, in that the hexadecimal digits in neighboring cells will agree on whether they share a wall or passageway, and each input will always have precisely two terminal cells, each with one missing exterior wall.

Our sample maze is a legitimate maze in that all cells are reachable and there is a unique simple path between any pairs of cells in the maze. Your goal is to write a program that reads the hexadecimal descriptions of a potential maze and tests to determine if it is legitimate. If there is a problem, your program must report only the first problem, as detailed below in the section titled "Output".

Input

The input consists of the descriptions of one or more candidate mazes. Each maze description will start with two integers, H and W, indicating the height and width of the maze, respectively, such that 1 ≤ H ≤ 50 and 2 ≤ W ≤ 50. Following this first line will be H rows of hexadecimal digits, with each row consisting of W digits. The input is terminated with a line displaying a pair of zeros.

Output

For each candidate maze, the program should output the first one of the following statements that applies: 

NO SOLUTION

UNREACHABLE CELL

MULTIPLE PATHS

MAZE OK

The classification statements are defined formally as follows:

NO SOLUTION - There is no path through the interior of the maze between the two exterior openings.

UNREACHABLE CELL - There is at least one cell in the maze that is not reachable by following passageways from either of the openings in the exterior walls of the maze.

MULTIPLE PATHS - There exists a pair of cells in the maze that have more than one simple path between them. Two simple paths are considered to be distinct if any part of the paths differ.

MAZE OK - None of the above problems exist.

Note well that for the second case given in the following examples, there is no path between the start and finish and there is an unreachable cell; the correct output should simply be NO SOLUTION, because that error message is listed first in the above list. Similarly, in the fourth example given, UNREACHABLE CELL is reported because that error has priority over the multiple paths.

Sample Input

6 7

9A8C98E

2E5753C

980A496

553C53C

53C75D5

3E3E363

3 3

F9A

D3E

3AC

1 8

3AAA8AAE

6 3

9AC

3C5

A24

9A6

5BC

3C7

5 4

8A8E

592C

5186

161C

3A63

5 4

8AAE

59AC

5386

1E1C

3A63

0 0

Sample Output

MAZE OK

NO SOLUTION

MAZE OK

UNREACHABLE CELL

MULTIPLE PATHS

MULTIPLE PATHS

Hint

同样是一个迷宫题,根据题意,确定每个点能够走的方向,然后进行一次简单的dfs

判断几个点,首先是迷宫的两个口是否联通,其次是是否有某个点到达不了,然后是

#include<cstdio>  
#include<cstring>
#include<queue>
#include<cstdio>
#include<algorithm>  
using namespace std;
const int N = 1e2 + 10;
int n, m;
int can[N][N][4];
char s[N][N];
int dir[4][2] = { 0,1,1,0,0,-1,-1,0 };
int sx, sy, tx, ty;
int Nos, Unr, Mul, vis[N][N];

enum direction {
  right = 0,
  down = 1,
  left = 2,
  up = 3
};

bool get(char c, direction d) {
  switch (d) {
    case right:
      return c == '0' || c == '1' || c == '2' || c == '3' || c == '8' || c == '9' || c == 'A' || c == 'B' || c == 0;
    case down:
      return c == '0' || c == '1' || c == '4' || c == '5' || c == '8' || c == '9' || c == 'C' || c == 'D' || c == 0;
    case left:
      return c == '0' || c == '2' || c == '4' || c == '6' || c == '8' || c == 'A' || c == 'C' || c == 'E' || c == 0;
    case up:
      return c == '0' || c == '1' || c == '2' || c == '3' || c == '4' || c == '5' || c == '6' || c == '7' || c == 0;
  }
  return false;
}

void dfs(int x, int y, int bx, int by) {
  vis[x][y] = 1; Unr++;
  if (x == tx&&y == ty) Nos = 1;
  for (int i = 0; i < 4; i++) {
    int X = x + dir[i][0];
    int Y = y + dir[i][1];
    if (X<1 || X>n || Y<1 || Y>m || !can[x][y][i]) continue;
    if (X == bx && Y == by) continue;
    if (vis[X][Y]) {
      Mul = 1; continue;
    }
    dfs(X, Y, x, y);
  }
}

int main(){
  while (~scanf("%d%d", &n, &m) && n + m) {
    memset(s, 0, sizeof s);
    for (int i = 1; i <= n; i++) {
      scanf("%s", s[i] + 1);
    }
    sx = sy = 0;
    for (int i = 1; i <= n; i++) {
      for (int j = 1; j <= m; j++) {
        can[i][j][right] = get(s[i][j], right) && get(s[i][j + 1], left);
        can[i][j][down] = get(s[i][j], down) && get(s[i + 1][j], up);
        can[i][j][left] = get(s[i][j], left) && get(s[i][j - 1], right);
        can[i][j][up] = get(s[i][j], up) && get(s[i - 1][j], down);
        for (int k = 0; k < 4; k++) {
          if (can[i][j][k] && !s[i + dir[k][0]][j + dir[k][1]]) {
            if (sx) tx = i, ty = j; else sx = i, sy = j;
          }
        }
      }
    }
    memset(vis, 0, sizeof(vis));
    Nos = Unr = Mul = 0;
    dfs(sx, sy, 0, 0);
    if (!Nos) {
      printf("NO SOLUTION\n"); 
    } else if (Unr < n*m) {
      printf("UNREACHABLE CELL\n"); 
    } else if (Mul) {
      printf("MULTIPLE PATHS\n"); 
    } else {
      printf("MAZE OK\n");
    }
  }
  return 0;
}