天天看点

nefu 677 以前真没这样用过,,,http://acm.nefu.edu.cn/JudgeOnline/problemshow.php?problem_id=677 descriptioninputoutputsample_inputsample_outputhint

http://acm.nefu.edu.cn/JudgeOnline/problemshow.php?problem_id=677

description

input

  There are several test cases.
  Each case contains 4 integers in a line, separated by space.
  Proceed to the end of file.      

output

  For each test case, output the time expressed by the digital clock such as Sample Output.      

sample_input

  1 2 5 6
  2 3 4 2      

sample_output

_  _  _ 
 | _||_ |_ 
 ||_  _||_|
 _  _     _ 
 _| _||_| _|
|_  _|  ||_       

hint

  The digits showed by the digital clock are as follows:
     _  _     _  _  _  _  _  _ 
   | _| _||_||_ |_   ||_||_|| |
   ||_  _|  | _||_|  ||_| _||_|      
应用三维字符数组:      
#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
char a[3][10][4]={{" _ ","  "," _ "," _ ","   "," _ "," _ "," _ "," _ "," _ "},
                  {"| |"," |"," _|"," _|","|_|","|_ ","|_ ","  |","|_|","|_|"},
                  {"|_|"," |","|_ "," _|","  |"," _|","|_|","  |","|_|"," _|"}
                 };
int n[5];
int main()
{
    while(~scanf("%d%d%d%d",&n[0],&n[1],&n[2],&n[3]))
    {
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<4;j++)
                printf("%s",a[i][n[j]]);
            puts("");
        }
    }
    return 0;
}
           
<br /><span id="_xhe_temp" width="0" height="0"><br /></span>