天天看点

hdu4006优先队列

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 1630    Accepted Submission(s): 740

Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3

I 1

I 2

I 3

Q

I 5

Q

I 4

Q

Sample Output

1

2

3

HintXiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
int main()
{
    int n,k;
    while(scanf("%d %d",&n,&k) == 2)
    {
        priority_queue<int,vector<int>,greater<int> > Q;
        for(int i = 1;i <= n;i++)
        {
            char opt;
            scanf(" %c",&opt);
            if(opt == 'I')
            {
                int a;
                scanf("%d",&a);
                Q.push(a);
                if(Q.size() > k)
                    Q.pop();
            }
            else
                printf("%d\n",Q.top());
        }
    }
}
           
#include <iostream>
#include <queue>
using namespace std;
struct pos
{
int count;
int num;
friend bool operator<(pos n1,pos n2)
{

return n1.num  > n2.num ;

}
};

int main()
{
pos p1;
int n,k;
int m;
char ch;
while(cin>>n>>k)
{
priority_queue<pos> p;
int count=0,j=0;
for(int i=0;i<n;i++)
{
cin>>ch;
if(ch=='I')
{cin>>m;
 p1.num =m;
 p1.count =j;
 j++;
 count++;
 if(count<=k)
 p.push (p1);
 else
{

/*p.push (p1);

p.pop ();*/

//double now=p.top().num;

if(m>p.top().num )

{

p.pop();

p.push (p1);

}

}

}

else

{

cout<<p.top ().num  <<endl;

}

}

}

return 0;

}

           

继续阅读