天天看点

PAT 1044 Shopping in Mars (25 分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).

Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).

Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10^​5 ), the total number of diamonds on the chain, and M (≤10^​8), the amount that the customer has to pay. Then the next line contains N positive numbers D​1​​ ⋯D​N(Di ≤103 for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
           

Sample Output 1:

1-5
4-6
7-8
11-11
           

Sample Input 2:

5 13
2 4 5 7 9
           

Sample Output 2:

2-4
4-5
           

分析:

1、直接暴力解会有三个超时,因为这个是累加数组,顺序递增,因此自然想到二分查找优化

2、而这道题不是一个简单的二分查找,而是找出第一个大于等于m的数,再进行判断;这样就不需要分两种情况查找了(查找等于m的,没有等于m的再找出他第一个大于m的数)

我的代码:

#include<cstdio>
#include<map>
using namespace std;
const int maxn = 100010;
const int INF = 100000010;
map<int,int> mp;
int n,m,hashtable[maxn] = {0},sum = 0,minvalue = INF;
int findFuc(int left,int right,int i)
{
    while (left < right)
    {
        int mid = left + (right - left) / 2;
        int diff = hashtable[mid] - hashtable[i];
        if (diff >= m)
            right = mid;
        else
            left = mid + 1;          
    }
    return left;
}
int main()
{
    scanf("%d%d",&n,&m);
    for (int i = 1 ;i <= n ;i++)
    {
        int num;
        scanf("%d",&num);
        sum += num;
        hashtable[i] = sum;
    }
    for (int i = 0 ;i <= n ;i++)
    {    
        int pos = findFuc(i + 1,n,i);
        int diff = hashtable[pos] - hashtable[i];
        if (diff > minvalue) continue;
        if (diff >= m)
        {
            if (diff < minvalue)
            {
                mp.clear();
                minvalue = diff;
            }
            if (diff <= minvalue) mp[i + 1] = pos;            
        }
    }
    for (auto it = mp.begin() ;it != mp.end() ;it++)
        printf("%d-%d\n",it->first,it->second);
    return 0;
}                 
           

继续阅读