天天看点

hdu1004Let the Balloon RiseLet the Balloon Rise

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 71810    Accepted Submission(s): 26743

Problem Description Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0
        

Sample Output

red
pink
  
  
    
  
  
    
  
  
   answer:
  
  
          
#include"stdio.h"
#include"iostream"
#include"cstring"
#include"string"
#include"map"
using namespace std;
int main()
{
    map<string,int>pop;
    int n,i,max;
    string s;
    
    while(scanf("%d",&n)&&n!=0)
    {
        pop.clear();
        for(i=0;i<n;i++)
        {
            cin>>s;
            pop[s]++;
        }
        max=-1;
        map<string,int>::iterator iter;
        for(iter=pop.begin();iter!=pop.end();iter++)
        {
            if(iter->second>max)
                max=iter->second;
        }
        for(iter=pop.begin();iter!=pop.end();iter++)
        {
            if(max==iter->second)
            {
                cout<<iter->first<<endl;
                break;
            }
        }
    } 
    return 0;
}
           

继续阅读