天天看点

joj1435

joj1435
 1435: Goldbach

Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
joj1435
3s 8192K 787 206 Standard

Goldbach's Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.

This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.

Input

An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2 15. The end of the input is indicated by a number 0.

Output

Each output line should contain an integer number. No other characters should appear in the output.

Sample Input

6
10
12
0
      

Sample Output

1
2
1
      

This problem is used for contest: 81  118 

#include <iostream>

#include <string.h>

#include <math.h>

#define N 1<<15

using namespace std;

int prime[40000]={0};

int num[N/2+10]={0};

int main()

{

    int count=0;

    for(int i=2;i<=N;i++)

    {

        bool temp=true;

        for(int j=2;j<=sqrtl(i);j++)

        {

            if(i%j==0)

            {

                temp=false;break;

            }

        }

        if(temp)

        prime[count++]=i;

    }

    for(int i=0;i<count;i++)

    {

        for(int j=i;j<count;j++)

        {

            if(prime[i]+prime[j]<=(1<<15)&&(prime[i]+prime[j])%2==0)

            {

                num[(prime[i]+prime[j])/2]++;

            }

        }

    }

    int n;

    num[2]=1;

    while(cin>>n,n)

    {

        cout<<num[n/2]<<endl;

    }

    return 0;

}

Submit / Problem List / Status / Discuss

上一篇: joj1004
下一篇: joj1966

继续阅读