天天看点

PAT甲级1045

1045. Favorite Color Stripe (30)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Eva is trying to make her own color stripe out of a given one. She would like to keep only her favorite colors in her favorite order by cutting off those unwanted pieces and sewing the remaining parts together to form her favorite color stripe.

It is said that a normal human eye can distinguish about less than 200 different colors, so Eva's favorite colors are limited. However the original stripe could be very long, and Eva would like to have the remaining favorite stripe with the maximum length. So she needs your help to find her the best result.

Note that the solution might not be unique, but you only have to tell her the maximum length. For example, given a stripe of colors {2 2 4 1 5 5 6 3 1 1 5 6}. If Eva's favorite colors are given in her favorite order as {2 3 1 5 6}, then she has 4 possible best solutions {2 2 1 1 1 5 6}, {2 2 1 5 5 5 6}, {2 2 1 5 5 6 6}, and {2 2 3 1 1 5 6}.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=200) which is the total number of colors involved (and hence the colors are numbered from 1 to N). Then the next line starts with a positive integer M (<=200) followed by M Eva's favorite color numbers given in her favorite order. Finally the third line starts with a positive integer L (<=10000) which is the length of the given stripe, followed by L colors on the stripe. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print in a line the maximum length of Eva's favorite stripe.

Sample Input:

6

5 2 3 1 5 6

12 2 2 4 1 5 5 6 3 1 1 5 6

Sample Output:

7

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 210;
const int maxL = 10010;
int N, M, L;
int color[maxn];
bool hashtable[maxn] = { false };
int stripe[maxL];
int priority[maxL];
int d[maxL];//状态
int main()
{
  scanf("%d", &N);
  scanf("%d", &M);
  for (int i = 0; i < M; i++)
  {
    scanf("%d", &color[i]);
    hashtable[color[i]] = true;//只比较这些数
    priority[color[i]] = i;//设置优先级
  }
  scanf("%d", &L);
  for (int i = 0; i < L; i++)
  {
    scanf("%d", &stripe[i]);
  }
  int ans = -1;
  for (int i = 0; i < L; i++)
  {
    if (hashtable[stripe[i]] == true)
    {
      d[i] = 1;//LIS初始化为1
      for (int j = 0; j < i; j++)
      {
        if (priority[stripe[i]] >= priority[stripe[j]] && d[j] + 1 > d[i])
          d[i] = d[j] + 1;
      }
      ans = max(d[i], ans);
    }
  }
  printf("%d\n", ans);
}      

继续阅读