天天看点

K - Anniversary party【树形dp】

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.

Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:

L K

It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line

0 0

Output

Output should contain the maximal sum of guests’ ratings.

Sample Input

7

1

1

1

1

1

1

1

1 3

2 3

6 4

7 4

4 5

3 5

0 0

Sample Output

5

思路:树形dp入门,找到根节点后,从根节点开始dp,是其子节点就dfs再更新,一直到叶子节点。

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=6005;

int n,x,y,dp[maxn][maxn],f[maxn],is[maxn],v[maxn];

void dfs(int root){
	v[root]=1;
	for(int i=1;i<=n;i++)
		if(v[i]==0&&f[i]==root)//如果i是root的儿子就进去 
		{
			dfs(i);
			dp[root][1]+=dp[i][0];                //  这两行就是自下向上更新 。
			dp[root][0]+=max(dp[i][0],dp[i][1]); //1代表选,0代表不选。
		}
}

int main()
{
	int root=0;
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
		scanf("%d",&dp[i][1]);
	while(scanf("%d%d",&x,&y))
	{
		if(x==0&&y==0)
			break;
		f[x]=y;
		is[x]++;
	}
	for(int i=1;i<=n;i++)//找根 
		if(is[i]==0){
			root=i;
			break;
		}
	dfs(root);
	printf("%d\n",max(dp[root][0],dp[root][1]));
}