天天看点

【POJ 2484】A Funny Game(对称博弈)AC代码 努力努力再努力

题意描述:有一个n个硬币摆成的环,Alice和Bob每次从里面取出一个或两个硬币,Alice先手,谁取到最后一个硬币谁就赢。

解题思路:这是一道对称博弈问题,如果硬币的数量小于等于2,Alice可以一下子拿走,数量大于2的时候,无论Alice拿1个还是两个,Bob都可以根据剩下硬币数量的奇偶性来决定拿1个还是2个,从而使得留给Alice的硬币数量为偶数(取走1个和2个,分别可以改变数量和保持数量的奇偶性),之后无论Alice取几个,Bob只需取同样的个数就能够取胜了。

Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 106) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)
【POJ 2484】A Funny Game(对称博弈)AC代码 努力努力再努力

Figure 1

Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)

Suppose that both Alice and Bob do their best in the game.

You are to write a program to determine who will finally win the game.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, if Alice win the game,output "Alice", otherwise output "Bob".

Sample Input

1
2
3
0
      
Sample Output
Alice
Alice
Bob
      

AC代码 

#include<stdio.h>				//对称博弈 
#include<iostream>
using namespace std;
int main()
{
	int n;
	while(~scanf("%d",&n)&&n)
	{
		if(n>2)
			printf("Bob\n");
		else
			printf("Alice\n");
	}	
	return 0;
} 
           

努力努力再努力

继续阅读