天天看点

Asteroids【匹配】【匈牙利算法】

Time Limit:1000MS Memory Limit:65536K

Total Submit:117 Accepted:72

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

  • Line 1: Two integers N and K, separated by a single space.
  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4

1 1

1 3

2 2

3 2

Sample Output

2

Hint

INPUT DETAILS:

The following diagram represents the data, where “X” is an asteroid and “.” is empty space:

X.X

.X.

.X.

OUTPUT DETAILS:

Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

中文翻译:

给出一个矩阵,上面有敌人,每个子弹可以打出一横行或者一竖行,问最少用多少子弹消灭都有敌人,如:

X.X

.X.

.X.

x表示敌人,显然用两个子弹就可以解决所有敌人。

解题思路

依旧是一道匈牙利算法的模板题。。。

例题+解析:过山车。。

我们把输入的每个敌人的位置的行和列连起来。(邻接矩阵和邻接表都可以,我用的邻接表)

二分图的两部,一部为行坐标,一部为列坐标。。。

代码

#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
int k,m,n,x,y,ans,kk,use[505],boy[505],h[505];
struct c{
	int x,next;
}a[505];
int find(int x){
	for(int i=h[x];i;i=a[i].next)
	{
		int t=a[i].x;
		if(use[t]==0)
		{
			use[t]=1;
			
			if(boy[t]==0||find(boy[t]))
			{
				boy[t]=x;
				return 1;
			}
		} 
	}
	return 0;
}
void add(int x,int y){
	a[++kk].x=y;
	a[kk].next=h[x];
	h[x]=kk;
}
int main(){
 
	scanf("%d%d",&n,&m);
	for(int i=1;i<=m;i++)
	{
		scanf("%d%d",&x,&y);
		add(x,y);
	}
	for(int i=1;i<=n;i++)
	{
		memset(use,0,sizeof(use));
		if(find(i))
			ans++;
	}
	printf("%d",ans);	
}
           

继续阅读