A proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most kcolors is called a (proper) k-coloring.
Now you are supposed to tell if a given coloring is a proper k-coloring.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 104), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.
After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.
Output Specification:
For each coloring, print in a line
k-coloring
if it is a proper
k
-coloring for some positive
k
, or
No
if not.
Sample Input:
10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9
Sample Output:
4-coloring
No
6-coloring
No
题目大意:给定N个顶点,M条边,题目规定一条边的两个顶点不能同色 。有则输出"NO",否则输出共有几种颜色。
代码如下:
#include <iostream>
#include <cstdio>
#include <unordered_set>
#include <cstring>
#include <algorithm>
using namespace std;
int col[10005];
struct node {
int x,y;
}Map[10005];
int main()
{
int N,M,K,color;
cin>>N>>M;
fill(col,col+N,-1);
for (int i=0;i<M;i++)
{
cin>>Map[i].x>>Map[i].y;
}
cin>>K;
for (int i=0;i<K;i++)
{
int flag=0;
unordered_set<int> s;//用unordered_set去重,统计颜色种类。
for (int j=0;j<N;j++)
{
cin>>color;
col[j]=color;
s.insert(color);
}
for(int j=0;j<M;j++)
{
if (col[Map[j].x]==col[Map[j].y])
{
flag=1;
break;
}
}
if (flag) cout<<"No"<<endl;
else cout<<s.size()<<"-coloring"<<endl;
}
return 0;
}
其他:
fill()函数参数:fill(first,last,val);
// first 为容器的首迭代器,last为容器的末迭代器,val为将要替换的值。
举例:
int a[200];
fill(a, a+100, 1);
注意:
fill()中 ,它的原理是把那一块单元赋成指定的值,也就是说任何值都可以
memset(),则是将s所指向的某一块内存中的每个字节的内容全部设置为ch指定的ASCII值,即0 、1