天天看点

PAT_A1002 | A+B for Polynomials1002 A+B for Polynomials (25分)end 

1002 A+B for Polynomials (25分)

This time, you are supposed to find A+BA+BA+B where AAA and BBB are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

KKK N1N_1N​1​​aN1a_{N_1}a​N​1​​​​N2N_2N​2​​aN2a_{N_2}a​N​2​​​​ ... NKN_KN​K​​aNKa_{N_K}a​N​K​​​​

where KKK is the number of nonzero terms in the polynomial, NiN_iN​i​​ and aNia_{N_i}a​N​i​​​​ (i=1,2,⋯,Ki=1, 2, \cdots , Ki=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤101 \le K \le 101≤K≤10,0≤NK<⋯<N2<N1≤10000 \le N_K < \cdots < N_2 < N_1 \le 10000≤N​K​​<⋯<N​2​​<N​1​​≤1000.

Output Specification:

For each test case you should output the sum of AAA and BBB in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
           

Sample Output:

3 2 1.5 1 2.9 0 3.2
           

可以看看我之前写的 一元多项式求和 / 积 ,内有数组表示法和改进的链表法。

这里我偷了个懒,就用数组法写的,代码如下:

//
// Created by LittleCat on 2020/1/26.
//
#include <cstdio>
#define MAX_EXPONENTS 1000

int main() {
    float a[MAX_EXPONENTS + 1] = {0}, b[MAX_EXPONENTS + 1] = {0};
    int k;

    /* 输入第一个多项式 */
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        float coefficients;
        int exponents;
        scanf("%d", &exponents);
        scanf("%f", &coefficients);
        a[exponents] += coefficients;
    }

    /* 输入第二个多项式 */
    scanf("%d", &k);
    for(int i = 0; i < k; i++) {
        float coefficients;
        int exponents;
        scanf("%d", &exponents);
        scanf("%f", &coefficients);
        b[exponents] += coefficients;
    }

    int num = 0;
    for(int i = 0; i <= MAX_EXPONENTS; i++) {
        a[i] += b[i];
        if(a[i] != 0)
            num++;
    }

    printf("%d", num);
    for(int i = MAX_EXPONENTS; i >= 0; i--) {
        if(a[i] != 0)
            printf(" %d %.1f", i, a[i]);
    }
}
           

end 

欢迎关注个人公众号“鸡翅编程”,这里是认真且乖巧的码农一枚,旨在用心写好每一篇文章,平常会把笔记汇总成推送更新~

PAT_A1002 | A+B for Polynomials1002 A+B for Polynomials (25分)end 

继续阅读