天天看点

1850 Code 字典序问题

Code

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4211 Accepted: 1899

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).

The coding system works like this:

• The words are arranged in the increasing order of their length.

• The words with the same length are arranged in lexicographical order (the order from the dictionary).

• We codify these words by their numbering, starting with a, as follows:

a - 1

b - 2

...

z - 26

ab - 27

...

az - 51

bc - 52

...

vwxyz - 83681

...

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.

Input

The only line contains a word. There are some constraints:

• The word is maximum 10 letters length

• The English alphabet has 26 characters.

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf      

Sample Output

55      
#include<iostream>
#include<cstdio>
#include<string>
using namespace std;
__int64 c(__int64 m,__int64 n)
{
    if(n==0||m>n) return 0;
        double f=1.0;__int64 i,t;
  if(n/2<m)t=n-m;
  else t=m;
  for(i=1;i<=t;i++){f*=n-i+1;f/=i;}
  return (__int64)f;
}
__int64 check(string str)
{
    for(__int64 i=0;i<str.size()-1;i++)
    {
        if(str[i]>=str[i+1]) return 0;
    }
    return 1;
}
int main()
{
    __int64 s[12]={0};
    for(__int64 i=1;i<=11;i++) s[i]=s[i-1]+c(i,26);
    string str;
    while(cin>>str)
    {
        if(!check(str)) {cout<<0<<endl;continue;}
        __int64 r=str.size();
        __int64 sum=c(r,26);
        for(__int64 i=1,l=r-1;i<=r;i++,l--) sum-=c(i,26-(str[l]-'a'+1));
        cout<<sum+s[r-1]<<endl;
    }
    return 0;
}