天天看点

hdoj 5025 Saving Tang Monk

B - BFS + 状态压缩

Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Submit

Status

Description

《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts. 

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do. 

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way. 

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in. 

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind). 

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.

Input

There are several test cases. 

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M). 

Then the N × N matrix follows. 

The input ends with N = 0 and M = 0.

Output

For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).

Sample Input

3 1

K.S

##1

1#T

3 1

K#T

.S#

1#.

3 2

K#T

.S.

21.

0 0 

Sample Output

5

impossible

状态压缩,,,每种状态只走一次。。。。。。。。。啦啦啦,,,,,,,,,,,,,,,

#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,kx,ky,jx,jy,kkk,ssss;
char map[105][105];
int xxx[6],yyy[6];
int zx[4]={0,0,-1,1};
int zy[4]={1,-1,0,0};
struct node{
	int xx,yy;
	int sky;
	int step;
	bool S[6];
	bool friend operator <(node kp,node lp){
		return kp.step>lp.step;
	}
};
bool guo[105][105][10];//每种状态下,路只走一次。。。。 
int dfs()
{
	memset(guo,false,sizeof(guo));
	priority_queue<node> Q;
	node now,qian;
	now.xx=kx;now.yy=ky;
	now.step=0;now.sky=0;
	for (int i=0;i<6;i++)
	now.S[i]=false;
	Q.push(now);
	while (!Q.empty())
	{
		qian=Q.top();
		Q.pop();
		int x,y;
		for (int i=0;i<4;i++)
		{
			now=qian;
			now.step++;
			x=now.xx+zx[i];y=now.yy+zy[i];
			if (guo[x][y][now.sky]||map[x][y]=='#'||x<0||y<0||x==n||y==n) continue;
			if (map[x][y]=='S')
			{
				for (int ii=0;ii<kkk;ii++)
				{
					if (xxx[ii]==x&&yyy[ii]==y) 
					{
						if (now.S[ii])//蛇已打过。。。。 
						{
							break;
						}
						else//蛇未打。。。。。 
						{
						    now.step++;
							now.S[ii]=true;
							break;
						}
					}
				}
			}
			else if (map[x][y]>='1'&&map[x][y]<='9')
			{
				if (now.sky==map[x][y]-'1')
				{
					now.sky++;
				}
			}
			else if (x==jx&&y==jy)
			{
				if (now.sky==m)
				{
					ssss=now.step;
					return true;
				}
			}
			guo[x][y][now.sky]=true;
			now.xx=x;now.yy=y;
			Q.push(now);
		}
	}
	return false;
}
int main()
{
	while (scanf("%d%d",&n,&m),n+m)
	{
		kkk=0;
		for (int i=0;i<n;i++)
		{
			scanf("%s",map[i]);
			for (int j=0;j<n;j++)
			if (map[i][j]=='K')
			{
				kx=i;ky=j;
			}
			else if (map[i][j]=='T')
			{
				jx=i;jy=j;
			}
			else if (map[i][j]=='S')
			{
				xxx[kkk]=i;
				yyy[kkk++]=j;
			}
		}
		if (dfs())
		printf("%d\n",ssss);
		else
		printf("impossible\n");
	}
	return 0;
}