天天看点

hdoj Robberies 2955 (概率Dp&&01背包) 好题Robberies

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 17580    Accepted Submission(s): 6494

Problem Description The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

hdoj Robberies 2955 (概率Dp&&01背包) 好题Robberies

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
        

Sample Output

2
4
6
  
  
   //题意:
  
  
   先给你小偷被抓的概率m与它准备去偷的银行的个数n。
  
  
   然后给你n个银行中每个银行的钱数和偷这个银行被抓的概率,求出小偷最多能偷多少钱。
  
  
   //转换:
  
  
   将n个银行的总钱数看做是背包容量,将成功逃跑的概率(1-m)作为目标,进行01背包就可求出。
  
  
   Hait:重在转化....
  
  
          
#include<stdio.h>
#include<string.h>
double max(double a,double b)
{
	return a>b?a:b;
}
int a[110];
double dp[10010],b[110];
int main()
{
	int t;
	int n,i,j,k,sum;
	double m,num;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf%d",&m,&n);
		m=1-m;
		sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d%lf",&a[i],&num);
			b[i]=1-num;
			sum+=a[i];
		}
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		for(i=1;i<=n;i++)
		{
			for(j=sum;j>=a[i];j--)
			{
				dp[j]=max(dp[j],dp[j-a[i]]*b[i]);
			}
		}
		for(i=sum;i>=0;i--)
		{
			if(dp[i]>=m)
			{
				printf("%d\n",i);
				break;
			}
		}
	}
	return 0;
}