天天看点

HDOJ_1001 Sum Problem

Problem Description

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1+ 2 + ... + n

Input

The input will consist of a series of integers n,one integer per line.

[consist] verb 存在 consist of 由什么组成

[Series of] 一系列,连续

Output

For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will 

be in the range of 32_bit signed integer.

[follow by] A is followed by B. A被B跟随

Sample Input

1

100

Sample Output

1

5050

问题描述

嘿,欢迎来到HDOJ(杭州电子大学OJ)

在这个问题中,你的任务是计算SUM(n) = 1 + 2 ... + n

输入

输入将由一系列整数n组成,一个整数一行

输出

对于每个实例,在一行中输出SUM(n),跟在一个空行之后。你可能要假设结果在32位整数范围之内。

输入样例

1

100

输出样例

1

5050

C++ 通过版:

#include<iostream>
using namespace std;

int main( void )
{
	
	int n;
	int sum = 0;
	
	
	while( cin >> n )
	{
		
		
		for( int j = 1; j <= n; j++ )
		{
			sum += j;
		}
		
		cout << sum << endl << endl;
		sum = 0;
	}
	return 0;
}


           

继续阅读