天天看点

Solution of ZOJ 1188 DNA Sorting

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file.

Sample Input

1

10 6

AACATGAAGG

TTTTGGCCAA

TTTGGCCAAA

GATCAGATTT

CCCGGGGGGA

ATCGATGCAT

Sample Output

CCCGGGGGGA

AACATGAAGG

GATCAGATTT

ATCGATGCAT

TTTTGGCCAA

TTTGGCCAAA

Source: East Central North America 1998

分析:此题关键点有二,一是容器的选择,二是逆序数的计算。下面给出我的实现代码,中间用到了multiset和functor:

#include <iostream>

#include <cstdio>

#include <string>

#include <set>

using namespace std;

int num_inver( const string & str )

{

int inv_num = 0;

for( int i = 0; i < str.size() - 1; ++i ) {

for( int j = i + 1; j < str.size(); ++j ) {

if( str[i] > str[j] )

++inv_num;

}

}

return inv_num;

}

struct DNACompare

{

bool operator()( const string & str1, const string & str2 )

{

return num_inver( str1 ) < num_inver( str2 );

}

};

int main()

{

multiset<string, DNACompare> seqs;

int num_blocks;

scanf("%d", &num_blocks);

while( num_blocks-- != 0 ) {

string line;

getline( cin, line );

int str_len, num_strs;

scanf( "%d %d", &str_len, &num_strs );

for( int j = 0; j < num_strs; ++j ) {

cin >> line;

seqs.insert( line );

}

multiset<string, DNACompare>::const_iterator iter;

for( iter = seqs.begin(); iter != seqs.end(); ++iter )

printf("%s/n", iter->c_str());

seqs.clear();

if( num_blocks != 0 )

printf("/n");

}

return 0;

}