天天看点

A-Text Reverse

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m'I morf .udh
I ekil .mca      

Sample Output

hello world!
I'm from hdu.
I like acm.
      

Hint

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

        
       

代码: 

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;


int main(){
    int n;
    cin>>n;
    getchar();    //读入换行符‘\n’
    while(n--){
        string str;
        getline(cin,str);   //getline()允许读入空格。
        int i=0;
        long long pos;
        while((pos=str.find(' ',i))!=string::npos){
            reverse(str.begin()+i,str.begin()+pos);//从第i歌字符开始到第pos-1个字符结束
            i=pos+1;
        }
        reverse(str.begin()+i,str.end());//从第i个字符开始到end的下一个位置
        cout<<str<<endl;
    }
    return 0;
}