描述
- 输入
-
The first Line of the input is a positive integer T,indicates the number of the test cases;
In every case,the input is in one line,contains two positive interger A,B
输出 - For every case,output the multiplication in Bessie's style. 样例输入
-
1 123 45
样例输出 -
54
来源 - POJ 上传者
- admin
思路:
这道题的大意就是题目中的一句话,例如输入123和45就输出1*4+1*5+2*4+2*5+3*4+3*5的值。
代码:
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
String[][] s = new String[n][2];
int[] sum = new int[n];
for(int i=0;i<n;i++){
for(int j=0;j<2;j++){
s[i][j] = sc.next();
}
}
for(int i=0;i<n;i++){
for(int j=0;j<s[i][0].length();j++){
for(int k=0;k<s[i][1].length();k++){
sum[i] += (s[i][0].charAt(j)-'0')*(s[i][1].charAt(k)-'0');
}
}
System.out.println(sum[i]);
}
}
}