天天看点

7-12 jmu-Java&Python-统计文字中的单词数量并按出现次数排序 (25分)(c++版)(虽然不是c++的题 (却被迫用c++做

(虽然不是c++的题

(却被迫用c++做

现在需要统计若干段文字(英文)中的单词数量,并且还需统计每个单词出现的次数。

注1:单词之间以空格(1个或多个空格)为间隔。

注2:忽略空行或者空格行。

基本版:

统计时,区分字母大小写,且不删除指定标点符号。

进阶版:

统计前,需要从文字中删除指定标点符号!.,😗?。 注意:所谓的删除,就是用1个空格替换掉相应字符。

统计单词时需要忽略单词的大小写。

输入说明

若干行英文,最后以!!!为结束。

输出说明

单词数量

出现次数排名前10的单词(次数按照降序排序,如果次数相同,则按照键值的字母升序排序)及出现次数。

输入样例1

failure is probably the fortification in your pole

it is like a peek your wallet as the thief when you

are thinking how to spend several hard-won lepta

when you are wondering whether new money it has laid

background because of you then at the heart of the

most lax alert and most low awareness and left it

godsend failed

!!!

输出样例1

46

the=4

it=3

you=3

and=2

are=2

is=2

most=2

of=2

when=2

your=2

输入样例2

Failure is probably The fortification in your pole!

It is like a peek your wallet as the thief when You

are thinking how to. spend several hard-won lepta.

when yoU are? wondering whether new money it has laid

background Because of: yOu?, then at the heart of the

Tom say: Who is the best? No one dare to say yes.

most lax alert and! most low awareness and* left it

godsend failed

!!!

输出样例2

54

the=5

is=3

it=3

you=3

and=2

are=2

most=2

of=2

say=2

to=2

#include<iostream>
#include<cstdio>
#include<string>
#include<ctime>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<stack>
#include<climits>
#include<queue>
#include<map>
#include<set>
#include<sstream>
#include<unordered_map>
using namespace std;
typedef long long ll;
int main()
{
    //鬼哦
    //又打了好几个小时
    //呜呜呜还是不太会map    
    string s,sum="";
    cin>>s;
    int i,flag=0,j,count=0;
        while(s!="!!!!!"){
        for(i=0;i<s.length();i++){
            if(s[i]=='!'||s[i]=='.'||s[i]==','||s[i]==':'||s[i]=='?'||s[i]=='*'){
                s[i]=' ';
            }
            if(s[i]>='A'&&s[i]<='Z'){
                s[i]+='a'-'A';
            }
        }
        sum=sum+s;
        sum+=" ";
        cin>>s;
    }
        map<string,int> mp;
    string ss="";
    for(i=0;i<sum.length();i++){
        if(sum[i]==' ')
        {
            if(ss=="")
            {
            }
            else
            {
                int key=mp.count(ss);
                if(key>0)
                {
                    mp[ss]++;
                }
                else
                {
                    mp.insert(pair<string,int>(ss,1));
                    count++;
                }
            } flag=0;
            ss.clear();
            }else{
            ss+=sum[i];
            flag++;
           }
       }
    map<string,int>::iterator p,g;
    p=mp.begin();
    //g=p;
    // cout<<g->frist<<g->second<<endl;
    cout<<count<<endl;
    for(j=0; j<10; j++)
    {
        p=mp.end();
        p--;
        map<string,int>::iterator i=mp.end();
       for(i--;i!=(--mp.begin()); i--)
        {
            if(i->second!=-1){
                if(p->second <= i->second){
                    //break;
                    p=i;
                }
            }
        }
        cout<<p->first<<"="<<p->second<<endl;
        mp[p->first]=-1;
    }
   // cout<<i->first<<","<<i->second<<endl;
    return 0;
}
           
pta