The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.
Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, NN (\le 10^4≤10
4
), the total number of users, KK (\le 5≤5), the total number of problems, and MM (\le 10^5≤10
5
), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to NN, and the problem id’s are from 1 to KK. The next line contains KK positive integers p[i] (i=1, …, KK), where p[i] corresponds to the full mark of the i-th problem. Then MM lines follow, each gives the information of a submission in the following format:
user_id problem_id partial_score_obtained
where partial_score_obtained is either -1−1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.
Output Specification:
For each test case, you are supposed to output the ranklist in the following format:
rank user_id total_score s[1] … s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.
The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.
Sample Input:
7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0
Sample Output:
1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
代码(部分正确19分,有1个点错了,一个点超时,不知道怎么改进了)
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <vector>
using namespace std;
struct user{
int id;
int perfect;
int sum;
int* score;
};
void Sum(struct user* user1,int K)
{
for ( int i = 0 ; i <K ; i++){
if (user1->score[i] != -1 && user1->score[i] != -2){
user1->sum += user1->score[i];
}else{
continue;
}
}
}
bool cmp(struct user user1,struct user user2)
{
if ( user1.sum > user2.sum){
return true;
}else if(user1.sum == user2.sum){
if ( user1.perfect > user2.perfect){
return true;
}else if (user1.perfect == user2.perfect){
if (user1.id < user2.id){
return true;
}
}
}
return false;
}
int main()
{
int N,K,M;
cin>>N>>K>>M;
int score[K];
struct user users[N+1];
vector<struct user> rank;
for ( int i = 1 ; i < N+1 ; i++){
users[i].score = new int[K];
for (int j = 0 ; j < K ; j++){
users[i].score[j] = -2;
}
users[i].sum = 0;
users[i].perfect = 0;
}
for ( int i = 0 ; i < K ; i++){
cin>>score[i];
}
for ( int i = 0 ; i < M ; i++){
int id,pro_id,num_obtain,index;
cin>>id>>pro_id>>num_obtain;
users[id].id = id;
if ( users[id].score[pro_id-1] < num_obtain){
users[id].score[pro_id-1] = num_obtain;
}
}
int flag;
for ( int i = 1 ; i < N+1 ; i++){
Sum(&users[i],K);
for ( int j = 0 ; j < K ; j++){
if ( users[i].score[j] == score[j]){
users[i].perfect++;
}
}
if ( users[i].sum != 0){
rank.push_back(users[i]);
}
}
sort(rank.begin(),rank.end(),cmp);
int r = 2;
int sum = 0;
for ( int i = 0 ; i < rank.size(); i++){
if ( i == 0){
cout<<i+1;
}else{
if ( rank[i].sum == rank[i-1].sum){
cout<<r;
}else{
cout<<i+1;
r = i+1;
}
}
printf(" %05d %d",rank[i].id,rank[i].sum);
for ( int j = 0 ; j < K ; j++){
if( rank[i].score[j] == -2){
cout<<" -";
}else if ( rank[i].score[j] == -1){
cout<<" 0";
}else{
cout<<" "<<rank[i].score[j];
}
}
cout<<endl;
}
return 0;
}
复制
