天天看点

HDU 1686 - Oulipo (KMP)

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN      

Sample Output

1
3
0      

题意:

       计算s2在s1中出现了几次。

思路:

      利用KMP, 只需要在s2串匹配完成后,flag++然后回溯。

代码:

#include<stdio.h>
#include<string.h>
char a[10010],b[1000010];
int next[10010];
int lena,lenb,c,n,flag;
void get_next()
{
	int i,j;
	i = 1;
	j = 0;
	while(i < lena)
	{
		if(j == 0 &&a[i] !=a[j])
		{
			next[i] = 0;
			i ++;
		}
		else if(j > 0 && a[i] != a[j])
		{
			j = next[j - 1];
		}
		else
		{
			next[i] = j + 1;
			i ++;
			j ++;
		}
	}
}
int kmp()
{
	int i = 0,j = 0,c = 0;
	flag = 0;
	while(i < lenb&& j < lena)
	{
		if(j ==0 && a[j] != b[i])
		{
			i++;
		}
		else if(j > 0 && a[j] != b[i])
		{
			j = next[j - 1];
		}
		else
		{	
			j ++;
			if(j == lena)
			{
				flag ++;
				j = next [j-1];
			}
			i ++;
		}
	}
	if(i >= lenb)
		printf("%d\n",flag);
}
int main()
{
	while(scanf("%d",&n)!=EOF)
	{
		while(n--)
		{
			getchar();
			scanf("%s%s",a,b);
			lena = strlen(a);
			lenb = strlen(b);
			get_next();
			kmp();
			memset(a,0,sizeof(a));
			memset(b,0,sizeof(b));
		 } 
		
	}
	return 0;
 }