天天看点

USACO broken necklace 破碎的项链

QUESTION

You have a necklace of N red, white, or blue beads (3<=N<=350) some of which are red, others blue, and others white, arranged at random. Here are two examples for n=29:

1 2                               1 2
        r b b r                           b r r b
      r         b                       b         b
     r           r                     b           r
    r             r                   w             r
   b               r                 w               w
  b                 b               r                 r
  b                 b               b                 b
  b                 b               r                 b
   r               r                 b               r
    b             r                   r             r
     b           r                     r           r
       r       r                         r       b
         r b r                             r r w
        Figure A                         Figure B
                    r red bead
                    b blue bead
                    w white bead
           

The beads considered first and second in the text that follows have been marked in the picture.

The configuration in Figure A may be represented as a string of b’s and r’s, where b represents a blue bead and r represents a red one, as follows: brbrrrbbbrrrrrbrrbbrbbbbrrrrb .

Suppose you are to break the necklace at some point, lay it out straight, and then collect beads of the same color from one end until you reach a bead of a different color, and do the same for the other end (which might not be of the same color as the beads collected before this).

Determine the point where the necklace should be broken so that the most number of beads can be collected.

EXAMPLE

For example, for the necklace in Figure A, 8 beads can be collected, with the breaking point either between bead 9 and bead 10 or else between bead 24 and bead 25.

In some necklaces, white beads had been included as shown in Figure B above. When collecting beads, a white bead that is encountered may be treated as either red or blue and then painted with the desired color. The string that represents this configuration can include any of the three symbols r, b and w.

Write a program to determine the largest number of beads that can be collected from a supplied necklace.

PROGRAM NAME: beads

INPUT FORMAT

Line 1: N, the number of beads

Line 2: a string of N characters, each of which is r, b, or w

SAMPLE INPUT (file beads.in)

29

wwwbbrwrbrbrrbrbrwrwwrbwrwrrb

OUTPUT FORMAT

A single line containing the maximum of number of beads that can be collected from the supplied necklace.

SAMPLE OUTPUT (file beads.out)

11

OUTPUT EXPLANATION

Consider two copies of the beads (kind of like being able to runaround the ends). The string of 11 is marked.

Two necklace copies joined here

v

wwwbbrwrbrbrrbrbrwrwwrbwrwrrb|wwwbbrwrbrbrrbrbrwrwwrbwrwrrb

*|

rrrrrb|bbbbb <-- assignments

5xr …#|##### 6xb

5+6 = 11 total

题目描述

你有一条由N个红色的,白色的,或蓝色的珠子组成的项链(3<=N<=350),珠子是随意安排的。 这里是 n=29 的二个例子:

第一和第二个珠子在图片中已经被作记号。

图片 A 中的项链可以用下面的字符串表示:

brbrrrbbbrrrrrbrrbbrbbbbrrrrb

假如你要在一些点打破项链,展开成一条直线,然后从一端开始收集同颜色的珠子直到你遇到一个不同的颜色珠子,在另一端做同样的事(颜色可能与在这之前收集的不同)。 确定应该在哪里打破项链来收集到最大数目的珠子。

例如,在图片 A 中的项链中,在珠子 9 和珠子 10 或珠子 24 和珠子 25 之间打断项链可以收集到8个珠子。

白色珠子什么意思?

在一些项链中还包括白色的珠子(如图片B) 所示。

当收集珠子的时候,一个被遇到的白色珠子可以被当做红色也可以被当做蓝色。

表现含有白珠项链的字符串将会包括三个符号 r , b 和 w 。

写一个程序来确定从一条被给出的项链可以收集到的珠子最大数目。

输入格式:

第 1 行: N, 珠子的数目

第 2 行: 一串长度为N的字符串, 每个字符是 r , b 或 w。

输出格式:

输出一行一个整数,表示从给出的项链中可以收集到的珠子的最大数量。

输入样例1:

29

wwwbbrwrbrbrrbrbrwrwwrbwrwrrb

输出样例1:

11

解题思路:

1.纯暴力

2.按照顺序一个一个点做,将那个点作为第一个点,后面的作为第二,第三。。。个点。也就是重新排序。这样可以方便很多。

3.如果左边第一个点时‘w’时先不判断,用一个tmp储存第一个不是‘w’的点,将那个点的字符作为tmp,之后每一个只要是tmpl就加一

4.从左往右搜。

5.如果右边第一个点时‘w’时先不判断,用一个tmp储存第一个不是‘w’的点,将那个点的字符作为tmp,之后每一个只要是tmpr就加一

6.从右往左搜。

7.int sum=l+r

8.if(sum>ans){ ans=sum; }

9.如果加起来大于输入的n,就直接输出n,else输出ans即可

代码:

#include<iostream>
#include<cstdio>
using namespace std;
int main(){
//freopen("beads.in","r",stdin);
//freopen("beads.out","w",stdout);
char bead[500];
int n;
cin>>n;
int ans=0;
for(int i=0;i<n;i++){ 
cin>>bead[i];
}
char bead1[500];
for(int i=0;i<n;i++){
bead1[i]=bead[i];
}
int l=0,r=0;
for(int i=0;i<n;i++){
l=0;
r=0;
for(int j=0;j<n;j++){
bead[(i+j)%n]=bead1[j];
}
//l
char ltmp='s';
int cnt=0;
for(int j=0;j<n;j++){
if(bead[j]=='w'){
l++;
}else{
cnt=j;
ltmp=bead[j];
break;
}
}
for(int j=cnt;j<n;j++){ 
if(ltmp==bead[j]||bead[j]=='w')
{ 
l++; 
}
else{ 
break; 
} 
} 

//r 
char rtmp='s'; 
cnt=0; 
for(int j=n-1;j>=0;j--){
if(bead[j]=='w'){
r++;
}else{
cnt=j;
rtmp=bead[j];
break;
}
}
for(int j=cnt;j>=0;j--){
if(rtmp==bead[j]||bead[j]=='w'){
r++;
}else{
break;
}
}
int sum=l+r;
if(sum>ans){
ans=sum;
}
}
if(ans>n){
ans=n;
}
cout<<ans<<endl;
return 0;
}